Support Article
Unable to reschedule agent due to computation errors
SA-9219
Summary
An agent is terminated with an error in production environment. This issue just happened once and it is highly sporadic.
Error Messages
2015-04-13 00:00:18,885 [.PRPCWorkManager : 4] [ STANDARD] [xxxABC:05.01.01] ( internal.async.AgentQueue) ERROR - runEnd(): Data-Admin-Operator-ID.ExtractAccessPointCSV; true @ 0: Unable to reschedule agent due to computation errors. Invalid delay interval: -18318
Steps to Reproduce
Schedule an agent to run at 12:00:00 midnight.
Root Cause
It happens when an agent is scheduled to run at 12:00:00 midnight; if it ends up being scheduled to run even a second prior to that, it would be the previous day in regards to the agent timezone that results in negative value in time calculation (Next Execution Time - Current Time).
Delay of 18 seconds is the actual run time of the agent in this case.
Resolution
It can be resolved by changing the scheduled start time from the top of the hour to 5 minute after the hour, that is, 12:05:00 AM EST (America/New_York). This would ensure that the agent would always be running on the same day.
Published January 31, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.