Support Article
Unable to save audio using the 'Attach Audio' feature
SA-8758
Summary
With the Pega Mobile 4.2 framework on Pega 7.1 and logging in using the "Pega Mobile" application, trying to save an audio file using the 'Attach Audio' feature and clicking the "Save" button, does not do anything.
Error Messages
Not Applicable.
Steps to Reproduce
1. Install "Pega Mobile" application on your mobile device.
2. Provide the PRPC system URL and use credentials, userid- mobilegallery password - rules.
3. Navigate to the "Attach Audio" feature.
4. Click "Attach Audio" to bring up the audio recorder on your mobile device. Record audio.
5. When done, you are automatically brought to the "Audio recording" popup screen that captures the Audio Name/Additional Info.
6. After entering the information, click on the "Save Audio" button.
Root Cause
This feature is not supported for several audio formats which includes testing the existing recording and playback capabilities of all device and browser combinations.
Resolution
The explanation for this behavior is as follows:
Support for audio recording is not completely built into the "Pega 7" mobile application. Although it appears in the mobile gallery, it does not mean it is supported with all product combinations. In this case, audio recording is only supported with the “Mobile Mashup SDK”, which is a separate product.
Published January 31, 2016 - Updated October 8, 2020
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