Support Article
Unable to update and save SMA URL in System > Settings
Summary
User has upgraded from PRPC 6.x to Pega 7.1.8. After user tries to change a URL in the Systems > Settings page and clicks on Save button, the screen refreshes and the old URLs were displaying. The newly added URL changes are not getting saved.
Error Messages
No error messages are displayed on screen. Tracer shows invalid Ruleset.
Steps to Reproduce
1. Login to Developer Portal as Administrator.
2. Click on Designer Studio> System> Settings> URLs.
3. Modify the SMA URL and click on save.
4. Refresh the screen after saving to check whether new changes are present.
Root Cause
The root cause of this behaviour was incorrect Ruleset (TestApp) which the URL settings were referring to.
The Ruleset (TestApp) was present earlier and user has removed it from Ruleset stack in Access Group. As this Ruleset does not exists in the user environment, the below error was shown in the Tracer.
Resolution
Perform the following local-change steps:
1. Login to Developer portal as Administrator.
2. Click on Records> SysAdmin> Dynamic System Settings.
3. In the Dynamic System Settings, search for SystemManagementURI.
4. Open SystemManagementURI and click on edit beside RS.
5. Update the RuleSet to Pega-ProcessCommander and save.
Published March 2, 2016 - Updated October 8, 2020
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