Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Updated values are not posted to server on Save or Submit click

SA-60347

Summary



Updating the check box, does not post the values to the server after clicking Submit or Save. On providing post value on change, values update at that time in UI however, after submitting, values revert to the old ones.


Error Messages



Not Applicable.


Steps to Reproduce

  1. Create three sections A, B and C
  2. Set A as the parent section and embed B and C in it
  3. Configure B and C with When expressions and 'Run Visibility on client' enabled
  4. Set the same check box with same property for both B and C
  5. Run a case with section A and click Save or Submit


Root Cause



A software use or operation error. On Save or Submit, both the values in the section are fetched and posted to the clipboard. This value takes precedence, hence, in the UI the latest value is displayed.


Resolution

Perform the following local-change:

Remove the Run visibility condition on the client when it is not required.



 
Suggest Edit

Published September 19, 2018 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us