Support Article
Upgrade error "${current.system.name}!BATCH" not found
SA-17455
Summary
Attempting to upgrade from PRPC 6.1 to Pega 7.1.8, the upgrade script encounters an error: com.pega.pegarules.pub.context.InvalidConfigurationException: Data-Admin-Requestor instance "${current.system.name}!BATCH" not found
Error Messages
com.pega.pegarules.pub.context.InvalidConfigurationException: Data-Admin-Requestor instance "${current.system.name}!BATCH" not found
Steps to Reproduce
- Run the installer
- Supply a DBA user/password and two schemas, for split-schema approach
- Choose to do rulebase cleanup
Root Cause
A software use or operation error. The correct procedure for upgrading from a single 6.x to split 7.x environment was not being followed.
Resolution
Here’s the explanation for the reported behavior:
Admin was attempting to upgrade from a single to split schema directly instead of following the 4 step process outlined in the Pega 7.1.x Upgrade Guide.
In general this is the process for upgrading from a single to split schema using one database.
- Migrate 6.x rules tables to new schema
- Upgrade new rules schema. Dummy data tables created in rules schema as part of upgrade step.
- Generate the rules schema objects, grant privileges between new rules and data schema.
- Upgrade data schema
- Post upgrade steps to run additional upgrade scripts, cleanup unused tables from rules and data schemas
Published January 31, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.