Support Article

Upgrade fails when running 'upgrade.bat --dataOnly true' command

SA-58980

Summary



When running the ' upgrade. bat --dataOnly true' command, the upgrade fails.


Error Messages



Checking Configuration Files:
[echo] Rules schema has been set to 'pega_rules'
[pega:getupgradefromversion] Failed to find current installed version of PRPC
[pega:getupgradefromversion] java.lang.IllegalStateException: Could not find latest product in the pr_data_admin_product table
[pega:getupgradefromversion] at com.pega.pegarules.util.deploy.DeployUpgradeVersionUtil.getUpgradeFromVersionDataOnly(DeployUpgradeVersionUtil.java:59)
[pega:getupgradefromversion] at com.pega.pegarules.util.deploy.DatabaseContentsChecker.checkCurrentPRPCVersion(DatabaseContentsChecker.java:214)
[pega:getupgradefromversion] at com.pega.pegarules.util.anttasks.GetUpgradeFromVersion.execute(GetUpgradeFromVersion.java:65)
[pega:getupgradefromversion] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:293)
[pega:getupgradefromversion] at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
[pega:getupgradefromversion] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
[pega:getupgradefromversion] at java.lang.reflect.Method.invoke(Method.java:498)
[pega:getupgradefromversion] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[pega:getupgradefromversion] at org.apache.tools.ant.Task.perform(Task.java:348)
[pega:getupgradefromversion] at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:68)
[pega:getupgradefromversion] at net.sf.antcontrib.logic.IfTask.execute(IfTask.java:197)
[pega:getupgradefromversion] at sun.reflect.GeneratedMethodAccessor21.invoke(Unknown Source)
[pega:getupgradefromversion] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
[pega:getupgradefromversion] at java.lang.reflect.Method.invoke(Method.java:498)
[pega:getupgradefromversion] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[pega:getupgradefromversion] at org.apache.tools.ant.TaskAdapter.execute(TaskAdapter.java:155)
[pega:getupgradefromversion] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:293)
[pega:getupgradefromversion] at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
[pega:getupgradefromversion] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
[pega:getupgradefromversion] at java.lang.reflect.Method.invoke(Method.java:498)
[pega:getupgradefromversion] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[pega:getupgradefromversion] at org.apache.tools.ant.Task.perform(Task.java:348)
[pega:getupgradefromversion] at org.apache.tools.ant.Target.execute(Target.java:435)
[pega:getupgradefromversion] at org.apache.tools.ant.Target.performTasks(Target.java:456)
[pega:getupgradefromversion] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1405)
[pega:getupgradefromversion] at org.apache.tools.ant.Project.executeTarget(Project.java:1376)
[pega:getupgradefromversion] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
[pega:getupgradefromversion] at org.apache.tools.ant.Project.executeTargets(Project.java:1260)
[pega:getupgradefromversion] at org.apache.tools.ant.Main.runBuild(Main.java:857)
[pega:getupgradefromversion] at org.apache.tools.ant.Main.startAnt(Main.java:236)
[pega:getupgradefromversion] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:287)
[pega:getupgradefromversion] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:113)

BUILD FAILED
/opt/software/media/Pega_v74/scripts/setupDatabase.xml:1578: Failed to find current installed version of PRPC

Total time: 22 seconds
Ant Process returned a non 0 value



Steps to Reproduce



Run the 'upgrade.bat --dataOnly true' command.


Root Cause



A software use or operation error.


Resolution



Here’s the explanation for the reported behavior:

The UPGRADE script was run instead of the UPDATE script.

'Upgrade' is to upgrade the platform version to another platform versoin

For example, upgrade PRPC 6 to Pega 7 platform version

'Update' is to update one version to another.

For example, update Pega 7.1 to Pega 7.1.9.

 

Published June 6, 2018 — Updated February 13, 2019

Have a question? Get answers now.

Visit the Pega Support Community to ask questions, engage in discussions, and help others.