Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Upgrade script fails with error message in the log

SA-3881

Summary



Upgrade script fails with error message in the log.

Error Messages



Caused by: com.pega.pegarules.pub.context.InvalidConfigurationException: Data-Admin-Requestor instance "prpc!BATCH" not found
...
[java] at com.pega.pegarules.session.internal.authorization.SessionAuthorization.reset(SessionAuthorization.java:437)
[java] at com.pega.pegarules.session.internal.authorization.SessionAuthorization.<init>(SessionAuthorization.java:239)


Steps to Reproduce



Upgrade the Rules schema using the Installation and Upgrade Assistant (IUA).


Root Cause



The system name in the setupDatabase.xml does not match the system name in the database.



Resolution



Change the system name in the setupDatabase.xml to match the system name of the upgrading system.

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us