Support Article
Upload document attempts to access CMIS even though disabled
SA-50788
Summary
On selecting a document to attach and on clicking Submit, the attachment does not display and the Cancel and Submit buttons are not visible. The system attempts to connect to a Content Management Interoperability Services (CMIS) connector though the Application rule does not have CMIS integration configured.
Error Messages
Tracer error: Unable to establish CMIS session
Steps to Reproduce
Execute the Pega Client Lifecycle Management (CLM) demo script, Step 38d (click Submit to return to the Monitor document collection' task).
Root Cause
A defect in Pegasystems’ code or rules. The When rules were missing when performing certain steps if the CMIS repository was used.
Resolution
Perform the following local-change to the below activities:
- Selectattachment: Add the When rule in Step 2 where Call pyCMISTreeNodesPreLoad is invoked.
The When rule condition is Application.pyCMISDatasource.pyEnabled!=false continue When, otherwise skip step. - UploadAndLinkDocument: Modify the When rule in step 11 to Application.pyCMISDatasource.pyEnabled!=false continue When, otherwise skip step where Call SelectAttachment is invoked.
- SearchDocuments: Add the When rule in step 7 to Application.pyCMISDatasource.pyEnabled!=false continue When, otherwise skip step where Call FindECMDocuments is invoked.
Tags:
Published November 29, 2018 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.