Support Article
URL redirected to infinite loop while SSO Logoff
SA-72144
Summary
With single sign-on (SSO), when performing any action in a stale session, the browser leads to an infinite loop instead of loading the login screen.
Error Messages
Ajax failure pops up with the following errors during URL redirect:
Failure loading keyboard preferences
Unable to update browser requestor details. Failure on ajax.
Steps to Reproduce
- Open any object from any worklist from the Manager portal.
- Open a different browser or the same browser from a different machine.
- Open the same work object as Step 1 (same environment) from the Manager portal worklist. Warning message displays as '<opened object> is currently being modified by <user name>' while opening the same object from another browser.
- A link or a button displays at the bottom of the page as 'End other session to release lock'. Click the link or button. Close the object tab.
- Reopen the same object from the second browser worklist. It opens without an error message.
- Navigate to the first browser.
- Perform any valid action on the previously opened work object (Step 1). The page loading enters an infinite loop.
Root Cause
Node crash occurs. That is, the cookie is present in the server and not in the browser.
Resolution
This behavior is currently not supported and is scheduled to be supported in a future Pega release.
Published February 20, 2019 - Updated December 2, 2021
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