Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

User's session times out after an hour on WebLogic

SA-59758

Summary



A user's access group is set to timeout after 8 hours. However, the session times out after just 1 hour and displays a modal window to enter user credentials. Entering Pega credentials, the user is unable to log back in.


Error Messages



Not Applicable


Steps to Reproduce

  1. Set a user's access group timeout to over an hour.
  2. Wait for an hour.


Root Cause



A defect or configuration issue in the operating environment. 

WebLogic has a default timeout of 1 hour when no timeout is set explicitly. After an hour, the WebLogic timeout is triggered.


Resolution



Make the following change to the operating environment:

In prweb.war, set the WebLogic timeout in the web.xml (repackage any .ear used if necessary).
<session-config>
<session-timeout>480</session-timeout>
</session-config>


Replace '480' with the desired WebLogic timeout, in minutes.


 

Published July 23, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us