Support Article
Validation does not fire after processing error
SA-9829
Summary
User is able to see a processing error where validation does not occur if client side validation is disabled on harness.
Error Messages
Not Applicable.
Steps to Reproduce
1. Re-save and disable option Enable Client Side Validation on HTML tab on Perform harness.
2. Create Single Value property "A", type Decimal.
3. Create Section "B". Add Property "A" to the layout.
4. Create Validation rule "V".
5. Create Flow Action "T" And refer Section "B". Add validation "V" in the Flow action.
6. Create Flow rule and add two assignments. First is the "T" , second is the "ActionStub".
7. Create new Test case work instance.
8. In "A" enter a alfabetic symbol (for example A) then press Submit. A processing error has occurred. Expected: A message has occured: "A" is not a valid decimal value".
4. Close active tab.
5. Create new Test case work instance.
6. At runtime enter a number and press Submit. A validation message has occured.
7. Enter a alfabetic symbol (for example G1) then press Submit. A message has occured: "___ is not a valid decimal value".
8. Enter a number then press Submit. Assignment has performed! A validation does not fire! Expected: A validation message should occur
Root Cause
The root cause of this problem is a defect in customer application code/rules.
Resolution
This issue is resolved through the following local-change :
Use the control "ISNonNegativeInteger" in the property and change the validation control
as below:
IF !@(Pega-RULES:Default).isNumber(.PropertyName)
Then a message displays.Test validation message and do not continue if validation fails.
Published June 12, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.