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Support Article

Validation error message disappears in CPM CSR portal.

SA-12433

Summary



Property-Set-Messages set through an activity disappear in a few seconds. An error message flashes briefly before it disappears.

Error Messages



Not Applicable

Steps to Reproduce



1. Log in to CPM CSR Portal.
2. Start Phone call interaction.
3. Enter invalid phone number and submit the form.


Root Cause



There is a rule, CPMRefreshDialogScript, which contains a function, reloadCoachingTips(), which places an Ajax call to run an Activity on the server. The success handler for the Ajax call then executes the below:

pega.u.d.refreshSection("CPMCoachingTipHolder","");

Rather than go back to the Server to get the new content, the client refreshes both this section and the enclosing section with the cached version of the sections as they rendered prior to the insertion of the error message.


Resolution



This reported behavior is resolved through the following local-change:

Replace
pega.u.d.refreshSection("CPMCoachingTipHolder","");

with
pega.u.d.reloadSection("CPMCoachingTipHolder","");

Published July 29, 2015 - Updated October 8, 2020

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