Support Article

Validation messages are not present in clipboard

SA-32193

Summary



User applied required conditional expression on a repeating dynamic layout and observed that the validation is happening but the error message is not appearing on the screen or it is not getting posted in clipboard as well.
 

Error Messages



Not Applicable 


Steps to Reproduce

  1. Create a repeating layout , put a text input or radio button inside that.
  2. Apply a "Required conditional expression" on this radio button. 
  3. Validation is happening but pega default error message is not appearing on the screen or in the clipboard as well.


Root Cause



The error messages doesn't get displayed on the clipboard, since the validation involved in the scenario is the client side validation, and hence the request is not made to the server , and hence message is not posted to the clipboard .

Resolution

Validation Messages appeared in Clip Board with local Change:
1) use the Obj-Validate in an post activity of flow action  
2) To
mark the property as required.




3) In actions tab : Add the action set : onClick -> Refresh this section 



4) configure the submit button in the application as : 



With this configuration , button is enabled only if user has selected some value to the required field. And once enabled, on click of the button, modal dialogue will be launched .

Published January 6, 2017 - Updated January 16, 2017

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.