Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

ValueGroups used in Answers Section for CheckBox not updated

SA-359

Summary



ValueGroups used in the Answers Section for Complex CheckBox are not getting removed if the question referencing them is no longer visible.

Error Messages



There is no error message.

Steps to Reproduce



1. Create a Complex Question with CheckBox.
2. Use Custom ValueGroups in Answer Section.
3. Control the visibility of this question based on another Simple Question Radio button.
4. First make the selection in a way that Complex Question is visible.
5. Do some selections on the Check Boxes in this question.
6. Check the clip board, ValueGroup will be populated.
7. Change the answer in Simple Question Radio button so that Complex Check Box question is hidden now.
8. ValueGroup still retains the value. Expected behavior values in ValueGroup should be wiped out.


Root Cause



The root cause of this problem is a defect in Pegasystems’ code/rules.


Resolution



This problem is solved by Hfix-9739.
 
Suggest Edit

Published March 7, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us