Support Article
Visual Segment not working
SA-35251
Summary
Visual segment does not complete. It always takes lengthy duration with Pega Marketing 7.21.
Error Messages
Not Applicable
Steps to Reproduce
1. Create visual criteria segment in Marketing Portal.
2. Select Search Type as "Is Null".
3. Select negation check box.
Root Cause
User was trying to set the "Is not null" criterion by following above steps.
Not sure why, but the segment run is not getting completed when 'is not null condition' is set using above combination.
Resolution
User is suggested to use count operator on lists instead and change the criterion to 'count > 0', which resolves the segment run issue.
Tags:
Published July 12, 2017 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.