Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Websphere Fixpack 35 causes server hung threads

SA-13008

Summary



After applying Websphere (WAS) 7 fixpack 35, PRPC server cannot start due to hung threads.


Error Messages



The following error is from wsfpp1lpdza433wspqa5Server:

[1/3/15 8:25:51:221 MST] 00000002 ThreadMonitor W CWWSR0605W: Thread "<ThreadName>" (00000016) has been active for 659104 milliseconds and may be hung. There is/are 1 thread(s) in total in the server that may be hung.
at java.io.UnixFileSystem.getBooleanAttributes0(Native Method)
at java.io.UnixFileSystem.getBooleanAttributes(UnixFileSystem.java:239)
at java.io.File.isDirectory(File.java:765)
at com.pega.pegarules.priv.context.web.WebSphereNodeInfo.traverseFind(WebSphereNodeInfo.java:341)
at com.pega.pegarules.priv.context.web.WebSphereNodeInfo.traverseFind(WebSphereNodeInfo.java:342)


Steps to Reproduce



Not reproducible internally, but in one particular user's environment: upgrade to WAS fixpack 35 and restart the server - system hung with hung threads as desribed in the summary. 


Root Cause



The root cause of this problem is in a third-party product: IBM Websphere.

Resolution



This issue is resolved by HFix-23128 by avoiding the traverseFind method.

 

Published August 12, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us