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Support Article

When a flow shape has 2 tickets the flow doesn't jump to shape

SA-42718

Summary



User has noticed that when a flow shape has more than one ticket defined and a ticket is set the flow does not jump. If the user removes all tickets from the shape except for one it works.


Error Messages



Not Applicable


Steps to Reproduce



Add more than 1 ticket to an assignment shape in a flow. Try to raise one of the tickets and the flow does not jump. Remove the tickets from the shape until only one remains. Try to raise the remaining ticket and the flow will jump.


Root Cause



When multiple tickets are configured, only if all the tickets are set, the flow jumps to the correct assignment. If any of the tickets is not set, theh flow will not jump. This is an expected bahavior.

Resolution



User can set multiple tickets for the same assignment shape. however, user needs to turn 'ON' both tickets to trigger (or jump) within the flow.

i.e. A shape needs to have two (or more) tickets to be set before control resumes at that shape.

User will have to call “Obj-Set-Tickets” activity with these multiple tickets set and should not forget to clear them before going ahead as we do in “SetTicket” activity.

Published August 26, 2017 - Updated October 8, 2020

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