Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

When submitting an assignment the values are not getting posted

SA-35169

Summary



While submitting a screen with fields configured to post values using refresh section action, intermittently the values selected by users are not getting posted


Error Messages



Not Applicable


Steps to Reproduce

  1. Configure two controls which both reference the same property within another section.
  2. Configure a button to trigger a refresh section.
  3. Launch the section and put values in one of the controls and click the button mentioned in step two.
  4. Observe the described behavior.

Root Cause



An issue in the custom application code or rules
The screen had two sections referring the same property being posted at the same time. The second overwriting the first.

Resolution

Perform the following local-change:

Update the section configuration to ensure only a single UI element referencing an individual property is present at a time.
Suggest Edit

Published March 26, 2017 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us