Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Work ID search does not work in Pega Platform 8.3

SA-98968

Summary



Unable to search for a work ID in the User portal.


Error Messages



Not Applicable


Steps to Reproduce



Search for the  work ID created in the User portal.


Root Cause



There were 40 applications at the users end and the sum of properties across all 40 applications breached the limit of 5000 fields in the Search index which used the same index with a legacy configuration. This is the Elastic Search limitation; and Indexation stopped for properties beyond that limit.


Resolution



Perform the following local-change:
Follow the below steps to use a dedicated index for classes for which the work ID search does not function:

1. In the Dynamic System Setting (DSS), set the below:


a. indexing/distributed/enable_onlyselectedfieldsinfulltextsearch – false
b. indexing/useDataInstances – true 

Alternatively, in Pega Dev Studio, navigate to System Settings > Search Landing Page (S-L-P): 

(i) Uncheck the 'For specific properties' option.
(ii) Uncheck 'Customize full text search' option.




After enabling the setting indexing/useDataInstances for the first time on an environment, stop the server, remove the existing index files, and start the server.

2. For each class that is searchable, create a Custom Search Properties (C-S-P) instance.
3. In each of the C-S-P of the pySearch index, enable the 'Use dedicated index' option.


A screenshot of a cell phone

Description automatically generated

4. In the C-S-P of the pySearch index, click the Save button.
5. Click the 'Create dedicated index' button (which displays after saving).
6. Navigate to the Search landing page (S-L-P) > Dedicated tab.
7. Execute the Re-index operation.

Published January 20, 2020 - Updated December 2, 2021

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us