Support Article
Work ID search does not work in Pega Platform 8.3
Summary
Unable to search for a work ID in the User portal.
Error Messages
Not Applicable
Steps to Reproduce
Search for the work ID created in the User portal.
Root Cause
There were 40 applications at the users end and the sum of properties across all 40 applications breached the limit of 5000 fields in the Search index which used the same index with a legacy configuration. This is the Elastic Search limitation; and Indexation stopped for properties beyond that limit.
Resolution
Perform the following local-change:
Follow the below steps to use a dedicated index for classes for which the work ID search does not function:
1. In the Dynamic System Setting (DSS), set the below:
a. indexing/distributed/enable_onlyselectedfieldsinfulltextsearch – false
b. indexing/useDataInstances – true
Alternatively, in Pega Dev Studio, navigate to System Settings > Search Landing Page (S-L-P):
(i) Uncheck the 'For specific properties' option.
(ii) Uncheck 'Customize full text search' option.
After enabling the setting indexing/useDataInstances for the first time on an environment, stop the server, remove the existing index files, and start the server.
2. For each class that is searchable, create a Custom Search Properties (C-S-P) instance.
3. In each of the C-S-P of the pySearch index, enable the 'Use dedicated index' option.
4. In the C-S-P of the pySearch index, click the Save button.
5. Click the 'Create dedicated index' button (which displays after saving).
6. Navigate to the Search landing page (S-L-P) > Dedicated tab.
7. Execute the Re-index operation.
Published January 20, 2020 - Updated December 2, 2021
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