Support Article
Work Object landing pages do not work
SA-69764
Summary
When creating new versions of work objects, the work objects do not display in the Search list for an already open Search window.
This occurs for all versioned work objects such as,
- Benefit
- Grouper
- Benefit Set
- Product Template
- Product
- Plan
- Network
Error Messages
Not Applicable
Steps to Reproduce
- Search for a Benefit and open the details to display the version list.
- Open a version of the Benefit and select Save As for a new version.
- Process the new version (minor or major does not matter).
- Approve the new Benefit version.
- Click the Refresh button. The benefit list is cleared from the Clipboard but D_GenerateRulesVersionList is still present.
- Search for the Benefit again and open the Details section. The new Benefit does not display because it does not regenerate D_GenerateRulesVersionList since it already exists for this context.
- Select a different Benefit detail or Close and Reopen the Search tab. The search will now display the new version.
Root Cause
A defect in Pegasystems’ code or rules.
On searching and refreshing the screen, the data page for the line details was not removed.
Resolution
Perform the following local-change:
On the Refresh icon, add an action to refresh the section by calling DeleteAllInstancesOfDataPage wihch passes in the D_GenerateRulesVersionList parameter.
An enhancement request, FDBK-29299, is created for consideration by Pega Product Management.
Tags:
Published January 18, 2019 - Updated December 2, 2021
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