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Support Article

Work Objects are getting stuck due to SLA issues

SA-17701

Summary



WorkObjects are getting stuck due to SLA issues.

Developer  has configured an SLA on an assignment that routes the assignment to the WorkBasket, when the goal time expires.


But after goal time reached and SLA is run, and  developer is able to operate on assignment which was earlier in the worklist, as well as on the assignment which got routed to the WorkBasket.


Error Messages



Not Applicable.


Steps to Reproduce



Not Applicable.


Root Cause



In the SLA escalation activity, call to AddAssign activity is made. 

 

AddAssign activity is called in escalation activity, and Addassign is creating another assignment.

This activity is used to create a new assignment , which is called during flow execution. It is not some thing that one must explicitly make a call to it .

Resolution



Comment the call to AddAssign to resolve the issue.

 

Published January 31, 2016 - Updated October 8, 2020

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