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Support Article

Work parties are not always properly indexed

SA-14563

Summary



Work parties are not always properly indexed. For example, if a case is opened it might show four work parties listed; however, the indexed table only shows three entries. 


Error Messages



Not Applicable.


Steps to Reproduce

  1. Create a parent case and child case.
  2. Run an activity to copy the work parties from the child case to the parent case.


Root Cause



An issue in the custom application code or rules. An activity is used to copy the work parties from the child object to a temporary page, and then call the addWorkObjectParty activity to add these work parties to the parent object. The pzIndexes field is included in the copy and causes an issue when the index is already on the parent object.

Resolution



The issue is resolved by modifying the custom activity to remove the pzIndexes property after the Page-Copy step.
Suggest Edit

Published September 23, 2015 - Updated October 8, 2020

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