Support Article
Work status not updated in work table
SA-7453
Summary
A user tries to cancel a work object in a screen flow by raising a ticket. The ticket is raised through a local action available from Action Menu and takes the user to the main flow. Once clicked, the screen is refreshed and displays the correct results. Tracer is showing ticket Raised successfully and work status updated to Resolved-Cancelled bu a database query shows the work status is not updated. When they click the work ID from "Recent" list to view the work in review harness again, they still see the assignment links.
Steps to Reproduce
1. Open a work object.
2. Click on "Action" menu.
3. Click on the custom Cancel local action
Root Cause
The root cause of this problem is a defect in developer application rules. They used a post activity from the cancel flow action to set the ticket. The activity had an Obj-Save method in one step but did not have any "Commit" step.
Resolution
This issue is resolved through the following local change:After the Obj-Save method add another step to run the "Commit".
Published January 31, 2016 - Updated October 8, 2020
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