Support Article
WorkGroup is not updating for particular user in stage and Prod
SA-35550
Summary
User-A modifies the workgroup in the Designer Studio and when accesses the CaseManager portal, the workgroup shown is not updated.
User-A’s operator profile shows the correct workgroup.
This is reported in the staging and production environment.
There is an existing working user(User-B) wherein the updated workgroup is shown correctly in the CaseManger portal’s Dashboard.
Error Messages
There is no error on UI; however, in the server log below snippet is reported:
... (ticcontent.StaticContentClient) ERROR - 404 on request: /dmz__EkQN9w6OWCSkK1T-7LfYwWUX9_inmkieWVZH34[*/spacescript.js; Referring URL: https://abc/prweb/PRServlet/dmz__EkQN9w6OWCSkK1T-7LfYwWUX9_inmkieWVZH34%5B*/!PS1__TABTHREAD1?pyactivitypzZZZ=...."font-size: 8pt;">
...[TABTHREAD1] ( rd.resolve.SqlReportResolver) ERROR User_B - An error occured during resolving the report definition - null
Steps to Reproduce
1. Navigate to User's or operator(User-A) profile.
2. Modify the Workgroup(say from WG1 to WG2).
3. Save the changes.
4. Login to CaseManger portal using User-A credentials and observe the WorkGroup under Dashboard.
Actual Behavior: WorkGroup is showns as WG1.
Expected Behavior: WorkGroup to be shown as WG2.
Root Cause
On comparing the working operator(User-B) and non-working operator(User-A), the activity pyGetManagerWorkGroups was checkout.
Resolution
For the non-working operator, that is,user-B, discarding the activity pyGetManagerWorkGroups (which was checked out) resolves the issue.
Published April 11, 2017 - Updated October 8, 2020
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