Support Article
WorkObject opened from search bar is not opening in a new window
SA-20884
Summary
When phone call object is created open other work objects like Service case can not be opened in a new tab but does open in the phone call work object tab.
Error Messages
Not Applicable
Steps to Reproduce
1. Configure top search to get Interaction and Service case work objects as results.
2. Launch Interaction portal.
3. Create a new phone call and navigate to Interaction Driver screen.
4. Then search from top search and click on a service case.
5. Observe that the service case is opened in Interaction tab even though they are not related.
Root Cause
Its reproduced in one of the in house sytem as well. If a phone call exists and a service case is opened, its opened in the same tab and does not create a new tab for service case. It is the behavior in system.
When service case is clicked, the work object is added to D_CPMServiceCaseRecents as there is a phone call already exists.
Resolution
If the context is set to Home before opening the service case the issue is solved.
Perform the following local-change: Call OOTB data transform "CPMSetHomeContext" of class "CPM-Portal" from an activity which is called as fisrt action for the onclick event of intent tasks(work objects) in the list view or repeating grid.
Published March 19, 2016 - Updated December 2, 2021
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