Support Article
Wrap-up Confirmation message is not appearing in Pega-7
SA-17341
Summary
Wrap-up Confirmation message is not popping up even when the service cases are open.
Error Messages
Not Applicable
Steps to Reproduce
- Launch an Interaction Portal
- Creat a Service Case
- Without completing the assignment of the service case Click On Wrap Up button.
We could observe that no alert or warning message is not popping up on the screen metioning that the service case is still open
Root Cause
Out of the Box Pega Support does not support the usecase.
Resolution
Perform the following local-change:
Configured when conditions on Wrap Up Button such that if service case exist for that interaction then an alert if thrown.
Below are the changes need to be included in the application in order to achieve the requested use case.
- Add the below function to pega_cpm_IP_EventManager text file.
pega.cpm.IP.showInFlightAlert = function()
{
alert("Please complete the inflight service processes before proceeding");
}
The When condition used
WithSc:

Condition of string A is
@LengthOfPageList(D_CPMServiceCaseRecents[D_CPMPortalContext.pyID].pxResults)
Configure 2 Wrap Ups with same configuration of OOTB
One for the case where No Service Cases will be present
Second for the case where Service Cases will be present
In First Wrap Up:
Visibility condition(When rule): CPMIsHeadLessWrapUp&&!WithSC
Wrap Button Actions Tab : No changes in the action tab.
Second Wrap Up:
Visibility condition(When rule): CPMIsHeadLessWrapUp&&WithSC
Wrap Button Actions Tab : Add an action Run Script and the value for function name is "pega.cpm.IP.showInFlightAlert"

Similarly Configure all the other Wrap Ups of the OOTB
One WithSC(With Service Cases)
One !WithSC(Without Service Cases)
Published January 31, 2016 - Updated December 2, 2021
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