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Application overview

Application overview
Pega Marketing is a comprehensive marketing automation solution that delivers inbound offer
management and outbound marketing campaigns on a single platform. Pega Marketing uses a
unique combination of predictive and adaptive analytics, real-time decisioning, and business process
management to dynamically manage cross-channel conversations (from offer design to fulfillment),
drive revenue, and expand customer lifetime value.

Implementation delivery methodology
In most cases, use a scrum-based, Agile delivery model for a Pega application implementation. In the
rare cases where a waterfall-based implementation methodology is better suited, use Pega’s Iterative
Waterfall approach. These two implementation methodologies help break down the work into
manageable components that you can deliver to production faster. The Pega delivery approach has
the following primary stages:
• Initiation stage
• Delivery stage

Initiation stage
In the Initiation stage, the implementation teams build the foundation or baseline of the application
and prepare for the work that is necessary to configure the first production release and subsequent
extended production releases. Keep in mind that the first production release is the minimal required
scope to go live into production. Other capabilities will be added as part of the extended production
releases. Building a strong foundation to support expansion and reuse is key to the success of an
implementation.
The Initiation stage is further organized into the following sub-stages:

Plan
Align the vision and roadmap to establish the foundation for the implementation. The Plan sub-stage
includes the following tasks:
l

Defining the production release milestone

l

Refining scope alignment
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Set up
Validate and review the Pega-provided features and capabilities to see if they meet your
requirements and expectations. This sub-stage includes the following tasks:
l

Establishing environments and processes

l

Creating the baseline application

l

Loading customer data

l

Demonstrating the baseline application

l

Reviewing artifacts from the solution assessment

l

Reviewing business needs and outcomes

Prepare
Prepare for the delivery of Pega Marketing by completing the following tasks:
l

Confirming resources

l

Enabling team members

l

Establishing governance

At the conclusion of the Initiation stage, the scope of the work for the first production release is
clearly defined. For Scrum, the scope of the work is represented in an initial backlog. For Iterative
Waterfall, a specification list and schedule are prepared and finalized.

Delivery stage
The Delivery stage is dependent on the methodology selected (Scrum or Iterative Waterfall). During
this stage, the delivery team designs, builds, configures, and tests the application by using the
selected implementation methodology. The goal is to accomplish the tasks that are described in this
document by organizing the Application Feature backlog so that the delivery team can configure the
application incrementally with the result being a fully tested and performance-tuned application in
production.
The Delivery stage is organized into the first production release and the extended production release
types.
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First production release
This release includes only the essential features that are defined during the solution proposal stage
and are required for the first release into production. The first production release should be
implemented in 90 days or less, depending on the scope of the essential features. This release type
includes the following features:
l

Core Pega-provided features

l

Extended features considered essential for your business

l

Key day-one integrations with your systems to get data that you require

Extended production release
This release includes the non-essential features that are defined during the solution proposal stage.
The following features are implemented incrementally after the first production release:
l

Non-essential Pega-provided features

l

Extended features that you have identified as required for your business

This guide provides information to support both Scrum and Iterative Waterfall implementation
methodologies during the first production release and the extended production release.

Prerequisites
Before you start your Pega Marketing implementation, ensure that you understand the following
information.
l

l

l

Supported browsers. Review the Platform Support Guide.
Basic functionality of the Pega Marketing application. For more information, see the Getting
Started with Pega Marketing course.
The Designer Studio basics
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Pega Marketing application stack
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Initiation stage
During this stage, the implementation teams build out the foundation or baseline of the application
and prepare for the work that is necessary to configure the first production release and subsequent
extended production releases. For more information, see .
The Initiation stage includes the following tasks:

Creating your application
The first step in implementing Pega Marketing to best meet your organization's needs is to create the
application on which your extended application will be built. Use the New Application wizard to
create your new application. The wizard creates the application structure for you.

1. Log in by entering the administrator user name with the password that you specified.
User Name: administrator@pega.com
2. Create the application by following the steps in Creating an application with the New Application
wizard.
On the What type of application do you want to build page, click Pega Marketing 7.31.

3. Log in to your new application after you create the appropriate operator IDs.
Note: All procedures in this guide require that you log in to your new application by entering
credentials for that application, unless otherwise noted.
The New Application wizard creates the application class structure for you. You can reuse the classes
and rulesets that are created by the wizard in future applications that you create. As you implement
this application and future applications, you can apply class hierarchy and inheritance principles
to help you decide where in the class structure to create your rules to improve the maintainability
and overall efficiency of your application.
For more information, see Class layers.

Note: Before you start building features, click Resources > Application guides and complete
the tasks in Initial Setup for Pega Marketing.
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Verifying installed rulesets
The following lists the highest level ruleset versions available after you run the New Application
wizard. Verify that your system includes these ruleset versions.

Note: If your system does not contain the following rulesets, the application was not created
correctly.

1. From the Designer Studio menu select Application > Structure > RuleSet Stack.
Note: If you are in the Pega Marketing portal, you may need to switch to the developer portal to
see this option. Click the Switch Portal icon near the search bar and select Developer.
2. Verify that the following ruleset versions are listed:
l

<your implementation application>:01.01.01
<your implementation application>-Artifacts:01-01-01
<your implementation application>-Rules:01-01-01
<your implementation application>:01-01-01
<your implementation application>Int:01-01-01

l

PegaMarketing_FieldMarketing:07.31 (Optional - Will appear only if installed.)
PegaMKT-FieldMarketing:07-31-01

l

PegaMarketing_FW:07.31
PegaMKT-Install:07-31
PegaMKT-MarketingProfile:07-31
PegaMKT-Portal:07-31
PegaMKT-Desktop:07-31
PegaMKT-RevisionManagement:07-31
PegaMKT-Engine:07-31
PegaMKT-Integration:07-31
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PegaMKT-MailUtilities:07-31
PegaMKT-Passbook:07-31
PegaMKT-PushNotification:07-31
PegaMKT-Security:07-31
l

PegaMarketing_FW_PreReqs:07.31
PegaFW-NPS:07-13-99
PegaFW-DashboardCharts:01-01-03
Pega-IAC:07-10-34

l

PegaDM:07.10
Pega-DecisionManager:07-10-34

l

UIKit:10.01
UI-Kit-7:10-01-01

l

PegaRULES:07.10
Pega-ProcessCommander:07-10-99

Creating operator accounts
The New Application Wizard for Pega Marketing creates the following default access groups:
l

l

l

<your implementation application>:MarketAdmins - This is an access group for administrators.
The default portal for operators in this access group is Designer Studio. This access group also
grants access to the Pega Marketing and Case Manager portals.
<your implementation application>:MarketManagers - This is an access group for managers. The
default portal for operators in this access group is the Pega Marketing portal.
<your implementation application>:MarketAnalysts - This is an access group for analysts and
other marketing users. The default portal for operators in this access group is the Pega Marketing
portal.

If your application stack includes Pega Field Marketing, the New Application Wizard also creates the
following Pega Field Marketing access groups:
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l

<your implementation application>:FieldMarketingManagers

l

<your implementation application>:FieldMarketers

Create operator accounts for users of your implementation Pega Marketing application and assign
them to the predefined user groups.

1. Log in as a Pega Platform administrator.
2. Create an operator account with one of the predefined Pega Marketing. For more information, see
Operator ID data instances – Completing the Create or Save As form. Keep in mind the settings
specific to Pega Marketing operators, as described below.

3. In the Access settings section on the Security tab, select Allow rule checkout.
4. Click Update password and enter the password for this operator, then click Submit.
5. Click Save.
6. Log off and log in as the operator you created.
7. Disable the Auto checkout on save as setting in the operator preferences. For more
information, see Updating Designer Studio preferences.

Tip: After creating the first operator record, open it in Designer Studio and click Save > Save as.
This creates a new operator record with all the settings and preferences you previously entered.

Updating the Manager field for your organization units
The New Application Wizard creates the organization structure for your application. For each
organization unit the wizard creates, specify the manager operator.

1. Log in as a Pega Platform administrator.
2. Click Records > Organization > Organization Unit. A list of all existing organization units is
displayed.

3. Click on a unit to select the manager operator.
4. In the Manager field in the Staff section, enter or select one of the operators with the <your
implementation application>:MarketManager access group.
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5. Click Save.
6. Repeat the procedure for every unit in your organization.

Configuring Microsite settings
If you have installed the MS.war file on a different machine than the one on which you have
deployed Pega Marketing, you need to modify the index.html file.

1. Navigate to the directory where the MS.war file has been deployed (for example,
Tomcat\webapps\MS).
2. Edit the file index.html and prepend the full URL to your system:
l

l

http://<hostname>:<port>/prweb?pyActivity=pzIncludeMashupScripts
http://<hostname>:<port>/prweb/PRRestService/PegaMKTMicrosite/Services/IncludeMicrosit
eScripts

3. In Designer Studio, open the application rule associated with the PegaNBAM:Agents access group.
4. In the application rule, go to the Integration & Security tab.
5. In the Mashup security section, add a new Trusted Origin and add the URL for the location of
the deployed MS.WAR file.
Note: Only operators who have the role PegaMarketing_FW:MicrositeAdmin can create Microsites.
By default, Marketing Analysts do not have this role. If an operator requires the ability to create
Microsites, associate the operator with an access group that contains the PegaMarketing_
FW:MicrositeAdmin role (refer to the Pega Platform help or the PDN for instructions on configuring
access groups).

Optional: Configuring your applications for Pega Customer
Relationship Management
These procedures are required only if you will use the Pega Customer Relationship Management

features to share data and service cases across the Pega Customer Service, Pega Sales Automation,
and Pega Marketing applications. These procedures involve configuration across all three
applications, and they include links to the other implementation guides as needed.
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Important: If you have installed industry-specific applications on top of Pega Customer Service and
Pega Sales Automation, complete these configuration steps in the industry applications, and not in
the Pega Customer Service or Pega Sales Automation applications. For instructions, see the
implementation guide for the industry application on the Pega PDN.

Prerequisites
Your Pega Customer Service, Pega Sales Automation, and Pega Marketing applications must already
be created as described in Creating your application.
To configure the Pega Customer Relationship Management features, complete the following steps:

1. For environments that include both Pega Customer Service and Pega Sales Automation, complete
the following steps.

a. Add the Pega Sales Automation implementation rulesets to your Pega Customer Service
application, and add the Pega Customer Service implementation rulesets to your Pega Sales
Automation application. See "Adding shared rulesets" in the Pega Customer Service or Pega
Sales Automation Implementation Guide on the Pega Customer Service product page or the
Pega Sales Automation product page.

b. Create an integration ruleset for your Pega Customer Service and Pega Sales Automation
applications, and then add the integration ruleset to the top of the ruleset stack for each
application. See "Creating integration rulesets" in the Pega Customer Service or Pega Sales
Automation Implementation Guide on the Pega Customer Service product page or the Pega
Sales Automation product page.

c. Enable the Pega Customer Relationship Management features. See "Enabling or disabling
shared features" in the Pega Customer Service or Pega Sales Automation Implementation
Guide on the Pega Customer Service product page or the Pega Sales Automation product page.
d. In your Pega Customer Service application, update the operator access groups to include the
CustomerService:CSRSalesAccess role that is required to access the shared features. See
"Updating access groups to have shared access" in the Pega Customer Service Implementation
Guide on the Pega Customer Service product page.
2. For environments that also include Pega Marketing, complete these additional steps.
a. Configure your Pega Customer Service application to support Pega Customer Decision Hub.
i. Enable Pega Customer Decision Hub. See "Configuring application settings" in the Pega
Customer Service Implementation Guide on the Pega Customer Service product page.
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ii. Configure Customer Decision Hub settings. For each setting, copy the rule to the highest
ruleset shared by Pega Customer Service and Pega Sales Automation, and save your
changes in that ruleset. See "Configuring Pega Customer Decision Hub" in the Pega

Customer Service Implementation Guide on the Pega Customer Service product page.
b. In Pega Marketing, configure the application to support the Pega Customer Relationship
Management features. See Optional: Configuring Pega Marketing to support the Pega
Customer Relationship Management features on page 35.

c. In your Pega Sales Automation application, configure the integration between Pega Sales
Automation and Pega Marketing. See "Configuring the integration between Pega Sales
Automation and Pega Marketing" in the Pega Sales Automation Implementation Guide on the
Pega Sales Automation product page.

d. In your Pega Sales Automation application, test the integration with Pega Marketing local
campaigns. See "Testing the Pega Sales Automation integration with Pega Marketing local
campaigns" in the Pega Sales Automation Implementation Guide on the Pega Sales
Automation product page.

e. In Pega Marketing, train the adaptive model for sales offers. See Optional: Configuring
Adaptive Decision Manager for sales offers on page 47.

f. In Pega Marketing, run a Marketing campaign for batch evaluation. See Optional: Running a
marketing campaign for batch evaluation on page 50.

g. In your Pega Sales Automation application, test the integration with Pega Marketing next best
offers. See "Testing the Pega Sales Automation integration with Pega Marketing next best
offers" in the Pega Sales Automation Implementation Guide on the Pega Sales Automation
product page.

Generating specification documents
To avoid duplicating existing features, review the following documents to familiarize yourself with
the default rules and rulesets of your application. During the solution assessment, a number of
requirements, specifications, and other artifacts are captured to represent the scope of the work. If
they are captured in the Pega Platform, these artifacts can be reused to streamline the first
production release scope identification.
You can export application specification and requirements artifacts from the Pega Platform, and then
import them into your new baseline application so that you can build on the content that has already
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been created. For more information, see Exporting specifications and requirements and

Importing specifications and requirements.
Follow these procedures to generate documents that define what is contained within your
application:
• Generating the Application profile
• Generating the Application document
• Generating the Specification document

Generating the Application profile
This document is created during the Sales stage and includes the process stages and steps, case
types, reports, requirements, specifications, participants, collaborators, and actors that are associated
with the implementation of your application. It is a document that defines the scope of the
application, and it also includes the results of the presale gap analysis.
When you generate this document, you can include process flow diagrams.
To generate the document, log into your application by entering your newly created credentials, and
follow the procedure in Generating an application profile document.

Generating the Application document
This document and its associated controls provide the ability to customize the presentation of the
application information based on the document's intended audience. When you run the Application
Document tool, you can include or exclude content by selecting and clearing various options.
During an implementation, this document reflects the current state of your application. The
Application Document tool automatically updates the content of your document as you modify and
extend your application to reflect additional requirements. If you have not yet built anything, the
content of this document is the same as the application profile.
To generate the document, log into your application by entering your newly-created credentials, and
follow the procedure in Generating an application document.

Generating the Specification document
This document shows all of the specifications and linked requirements associated with your
application at the time that you generate the document. You can generate this document at any point
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during the implementation life cycle to include any updates to the application's specifications and
requirements.
Review this document before and after each sprint by using the available filters to tailor the content
to meet the business requirements of your implementation.
To generate the document, log into your application by entering your newly-created credentials, and
follow the procedure in Generating a specification document.
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Delivery stage
During this stage, the delivery team designs, builds, configures, and tests the application by using the
selected implementation methodology. For more information, see Implementation delivery
methodology
The Delivery stage includes the following tasks:
l

Defining requirements

l

Building features

l

Testing a new application

l

Packaging a new application
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Defining requirements
To ensure that you stay on target for a successful deployment, use a structured approach for your
implementation methodology. You will need to prepare for your implementation and determine key
aspects of the design that will affect the behavior of your application. Defining requirements for an
implementation includes the following tasks:
l

Reviewing extension requirements

l

Refining customizations and determining the availability of required data and integrations

l

Prioritizing, for example, revising the solution backlog, re-estimating the effort for extensions and
customizations, and confirming the project scope

Defining your requirements also involves DCO sessions and incorporating those requirements into
the application design. During these sessions, you review each of the case types and process flows
that the application already provides.
Update the Application Specifications with planned changes as described in About Application

Specifications.
The Implementation Planning Workbook helps you capture decisions as you define your
requirements. You can download the Implementation Planning Workbook from the Pega Marketing

product page.
Tip: Pega Marketing provides an interactive Initial Setup guide that can walk you through the
process of deploying your application. To review the guide before you begin, click Resources >
Application Guides > Initial Setup for Pega Marketing.
• Mapping your application data
• Defining integration
• Application data model
• Defining the security model and organization structure
• Defining reporting requirements
• Defining the business issues and groups
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Mapping your application data
The application data types provide a default set of properties for your use. You can add or remove
properties from these data types depending on your requirements. You can also add new data types.
Use the "Data model" worksheet in the Implementation Planning Workbook to record your decisions
during this procedure.

1. In the Designer Studio Explorer panel, click Data.
2. Click the data type that you want to modify.
3. On the Data model tab, determine the properties to add, remove, or leave unchanged. For more
information about data types, see Viewing data type details. Repeat these steps for any other data
types, as necessary.

Defining the customer class
Pega Marketing requires a customer class to support the loading of customer data.
To record your decisions during this procedure, use the "Customer class and associated entities"
worksheet in the Implementation Planning Workbook.

1. Define a name for the customer class.
2. Identify the customer class key. The default key property is CustomerID.
3. Identify the ruleset for the customer class.
4. Identify the associated entities (for example, PurchaseData) for this customer class.

Defining the prospect class
A prospect is a potential customer that business users want to target. Pega Marketing requires a
prospect class to support the loading of prospect data.
The base prospect class is PegaMKT-Data-Prospect. If the base prospect class is not sufficient, then
you must extend the class by creating and configuring a custom prospect class. For example, if the
default configuration does not capture all the potential customer data that you require, you can
adjust the data table that contains prospect information.
To record your decisions during this procedure, use the "Prospect class" worksheet in the

Implementation Planning Workbook.
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1. Define a name for the prospect class.
2. Identify the ruleset for the prospect class.
3. Identify the structure required for the list of prospects. Specify the properties on the prospect
record and their backing columns in the prospect table. Ensure that the structure meets the
following requirements.
l

The property name starts with a period

l

The table does not contain empty rows

l

The column name does not exceed 27 characters

Defining integration
You can inventory the external applications and databases that exist at your site and plan how to
connect to them.

Tip: When planning, identify integration points as early as possible. If a connection to an external
data source is required, and either the data itself does not exist or the interface to that data does not
exist, you must account for the time that is required to build the interface to the application.
For information about application data types and the corresponding sources for the data, see

Viewing external data entities.
To record your decisions during this procedure, use the Integration worksheet in the Implementation

Planning Workbook.
1. Identify all integration points for your application.
2. Identify which data is needed from each system of record, if you have not already done so.
3. Determine whether an interface to that system of record already exists and how to connect to it.
For more information, see Integration.

Defining email accounts
Pega Marketing uses the following two Outbound email accounts to manage outbound email
transactions.
l

Default — This system-wide default account for sending emails is also the default account for
sending email and Passbook treatments in offers.
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l

PegaMKT-Work — Used to send campaign-centric emails such as campaign approved and
campaign suspended.

To record your decisions during this procedure, use the "Email and SMS accounts" worksheet in the

Implementation Planning Workbook.
1. Define the following information for the Default email account.
l

Email provider

l

Sender name

l

From email address

l

User ID

l

Password

l

Reply to email address

l

SMTP host name

l

SMTP port number

l

Use SMTPS?

l

Keystore instance (message signing)

l

Certificate alias (message signing)

2. Define the following information for the PegaMKT-Work email account.
l

Email provider

l

Sender name

l

From email address

l

User ID

l

Password

l

Reply to email address

l

SMTP host name
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l

SMTP port number

l

Use SMTPS?

l

Keystore instance (message signing)

l

Certificate alias (message signing)

Note: You can install prepackaged connectors for email service providers (ESPs) Mailgun, SendGrid,
and Mailjet. The connectors help reduce deployment time by automating the configuration of an
email account. ESP connector packages are available for download on Pega Exchange.

Defining outbound SMS accounts
Pega Marketing uses the Pega-provided Default account to send SMS treatments in offers.
To record your decisions during this procedure, use the "Email and SMS accounts" worksheet in the

Implementation Planning Workbook.
1. Define the following information for the outbound SMS account.
l

Account name

l

Host address

l

Host port

l

User ID

l

Password

l

Test number

l

Sender's number

l

Maximum connections

l

Restrict sending of offer message to a specific time frame?

2. Define the following advanced settings for the outbound SMS account.
l

Unit cost

l

Source TON
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l

Source NPI

l

Response timeout in seconds

l

Max number of retries

l

Character encoding type

l

Reconnect on disconnect?

3. If required, define the name and value of any additional SMPP properties for this account.

Defining inbound SMS accounts
Pega Marketing uses inbound SMS accounts to listen for customer responses to offers and to take the
next appropriate action.
For more information, see Configuring an inbound SMS account in the Pega Marketing User Guide
on the Pega Marketing product page.
To record your decisions during this procedure, use the "Email and SMS accounts" worksheet in the

Implementation Planning Workbook.
1. Define the following information for the inbound SMS account.
l

Account name

l

Host address

l

Host port

l

Inbox address

l

Host IP address

l

User ID

l

Password

l

Reconnect time (seconds)

l

Response timeout (seconds)

l

Maximum number of retries

2. If required, define the name and value of any additional SMPP properties for this account.
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Defining push notifications
Pega Marketing can send push notification messages to registered apps. Push notifications can be
sent while running offers.
For more information, see the Push notifications chapter in the Pega Marketing User Guide on the

Pega Marketing product page.
To record your decisions during this procedure, use the "Push notification" worksheet in the

Implementation Planning Workbook.
1. For every app, define the following information.
l

Name of the app - how the app is referred to within the Pega Marketing application, for
example, in Offer flows

l

Description

l

Platform of the app - select Android or iOS

l

Unique ID - used for validating push notification service requests, for example, for registering
and un-registering app users

2. Define additional information.
l

For an Android app, define the Google key.

l

For an iOS app, define the following additional information.
App certificate - an Apple .p12 certificate
Certificate name - used for storing the certificate in the system
Certificate password - used to validate the certificate
Certificate type
Monitor Apple's notification feedback service?

Application data model
The application provides a set of data types, data pages, and sample data, which you can use to begin
implementing your application.
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Data modeling involves creating a conceptual model of how data items relate to each other in an
application. In the Pega Platform, the data model refers to a set of rules that work together to
populate the data in your application. The system displays this data to help you process the
information and can help you make decisions in your sales processes. The following rule types
constitute your data model:

Data types
Data type is another name for a class in your application. It holds data that the application uses. A
data type has one or more data pages and several property definitions associated with it.

Properties
Properties define the format and visual presentation of data in your application.

Data pages
Data pages define the content of a clipboard page. Data pages also control the loading of that data
from a source system, as shown here.

When planning your data model, work with the data modeling resource at your site to understand
the attributes of the data types that need to be supported by your application.

Note: Pega Marketing uses Pega's system of record for application data. Optional: You can integrate
your application data with your Pega's system of record.

Adding properties to data types
Data types categorize the data that your application uses. The data types that come with your
application have one or more data pages associated with them. Add properties to a data type to
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further customize it, for example, by adding contact information to a data type that represents a user
of your application.

1. In the Designer Studio Explorer panel, click Data.
2. Click the data type that you want to modify.
3. On the Data model tab, scroll to the bottom.
4. To add a property, click Add field. Add as many properties as your application requires. Repeat
these steps for any other data types, as necessary.
For more information about data types, see Data type management.
For information about data pages, see Data pages.
For information about adding data types, see Creating a new data type.

Defining the security model and organization structure
Security planning involves defining authorization and authentication strategies for your application.
l

Authentication
Proves to the application that you are who you say you are.

l

Authorization
Determines the functions that you can perform in the application. This corresponds to access
group and role configuration.

Security planning also involves setting up the organization structure and operator attributes.
The application provides security in the form of access settings and denial rules. Many integration
rules also incorporate authentication.
For more information about the additional aspects of security, enroll in the Lead System Architect
course on Pega Academy and cover the Security lessons that correspond to the following topics:
• Authentication schemes
• Defining your authentication scheme
• Defining your access groups
• Defining access roles and privileges
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• Defining the work groups
• Defining the workbaskets

Authentication schemes
The Pega Platform offers the following authentication types:

PRBasic
Based on passwords in the Operator ID data instances and the login form. This is defined by the
HTML @baseclass.Web-Login rule, which your application can override.

PRSecuredBasic
Similar to PRBasic, but passes credentials using Secure Sockets Layer (SSL) using Basic HTTP
authentication. The login form is defined by the HTML @baseclass.Web-Login-SecuredBasic rule,
which your application can override.

PRCustom
Supports access to an external LDAP directory or a custom authentication scheme.

PRExtAssign
Supports external assignments (Directed Web Access).

J2EEContext
Specifies that the application server in which the Pega Platform is deployed uses JAAS to
authenticate users.

Defining your authentication scheme
Your site can use a centralized, automated means of maintaining operator data instead of
maintaining it manually in your application.
To record your decisions during this procedure, use the "Security Model" worksheet in the

Implementation Planning Workbook.
1. Discuss Authentication schemes with your site's security and application server teams.
2. Determine the appropriate authentication type.
For more information on authentication scheme planning, see Authentication in the Pega

Platform.
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Defining your access groups
To record your decisions during this procedure, use the "Security model" worksheet in the

Implementation Planning Workbook.
1. Identify additional access groups that are needed for your application.
2. Identify portals associated with these access groups.
For more information, see Viewing access groups and operators.

Defining access roles and privileges
You can associate one or more roles with an access group. Roles are additive. The more roles that
you add to an access group, the more authorization there is. Privileges can be associated with one or
more roles.
To record your decisions during this procedure, use the "Security model" worksheet in the

Implementation Planning Workbook.
1. Determine which roles are needed for your application. You can use the Pega Marketing roles as a
starting point.

2. Determine which privileges to associate with each role.
3. Associate each role with an access group.
For more configuration information, see Groups and roles.

Defining the work groups
A work group determines which workbaskets you can access.

1. Click Designer Studio > Org & Security > Tools > Work Groups to display a list of
associated work groups.

2. Review and modify the list if necessary.
For more information, see Initial Work Groups.

Defining the workbaskets
A workbasket is a queue of open assignments in the application.
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1. Click Designer Studio > Org & Security > Tools > Work Baskets to display a list of
workbaskets.

2. Review and modify the list if necessary.
For more information, see Initial Workbaskets.

Defining reporting requirements
Based on your login and portal, your application provides numerous pre-configured reports to
monitor case and work inventory as well as monitor workforce productivity and quality. These
standard reports are driven by the case and work object life-cycle infrastructure as well as the work
and assignment-level service level rules for goals and deadlines used in managing the life cycle of a
case.

Defining the business issues and groups
Business issues represent major business objectives that users process and report on. Business
groups represent sub-categories of business issues.
The following list shows examples of different business issues and the groups for each of those
issues.
l

Retention
Proactive
Reactive
Preemptive

l

Sales
Cross Sell
Up-Sell
Promotions
Right-Size
Coupons
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l

Collections
Pre Collections
Post Collections
Promise To Pay

l

Risk

l

Education

l

Brand Awareness

To record your decisions during this procedure, use the worksheet in "Business issues and groups" in
the Implementation Planning Workbook.

1. Identify the business issues required for your implementation.
2. Identify the business groups required for your implementation.
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Building features
As you build and modify features, update the Application Specifications to reflect the changes. For
instructions, see About Application Specifications.

Tip: Pega Marketing provides an interactive Initial Setup guide that can walk you through the
process of deploying your application. You can complete the steps described in this chapter by
following the Initial Setup guide and using the Pega Marketing 7.31 Implementation Guide as
reference. To begin, click Resources > Application guides > Initial Setup for Pega

Marketing.
To build application features, complete the following steps:
• Configuring access groups and roles
• Configuring the Decisioning hierarchy
• Configuring the customer class
• Configuring the prospect class
• Configuring channels
• Reports
• Optional: Configuring Adaptive Decision Manager for sales offers
• Marketing assets configuration
• Optional: Running a marketing campaign for batch evaluation
• Verifying the System Health page

Configuring access groups and roles
It is a best practice to create new access groups and roles that are based on the default access groups
and roles that come with the product. This insulates your application from changes if the roles and
groups change permissions in a future release. Refer to the roles and groups that you identified
during the procedures.
To update an access group:
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1. Click Designer Studio > Org & Security > Groups & Roles > Access Groups.
2. Select the access group that you want to copy.
3. Click Save as to save the role to your application.
It is recommended that you name the role with a different name. Update the roles to use the ones
that you created for your application.

4. Click Create and open .
5. In the Definition tab, map the Name and Version field details with your application and click
Save.
To update an access role:

1. Click Designer Studio > Org & Security > Groups & Roles > Access Roles.
2. Select the access role that you want to copy.
3. Click Save as to save the role to your application. It is recommended to give the role a different
name.

4. Click Create and open .
5. Click Save.

Configuring the Decisioning hierarchy
Propositions are stored in a hierarchy that is comprised of business issues and groups. For more
information, see Proposition Management landing page.
Before using Pega Marketing, to configure the decisioning hierarchy, perform the following tasks.
• Optional: Configuring the top-level Strategy Result class
• Adding business issues and groups
• Optional: Configuring Pega Marketing to support the Pega Customer Relationship Management
features
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Optional: Configuring the top-level Strategy Result class
The class that represents the top of the decisioning hierarchy is referred to as the top level Strategy
Result (SR) class. The New Application wizard automatically creates the top-level SR class.
Some implementations require selecting a top-level SR class different than the default one. For
example, if the requirement is to create a new application and use an existing top-level SR class that
contains a configured decisioning hierarchy, you must reference the existing SR class.

1. Log in to Designer Studio.
2. Click Designer Studio > Decisioning > Decisions > Proposition Management
> Hierarchy.
3. In the Top Level section, click the class listed as the Top level class.
4. In the To field, enter the name of your preferred top-level SR class.
5. Click Save.

Adding business issues and groups
Create new business issues and groups that you can use in your Pega Marketing application.

1. Log in to Designer Studio.
2. Click Designer Studio > Decisioning > Decisions > Proposition Management >
Hierarchy.
3. Follow the instructions to create new business issues and groups as described in Creating a
business issue and Creating a group.

Optional: Configuring Pega Marketing to support the Pega Customer
Relationship Management features
If you want to use Pega Marketing with the Pega Customer Relationship Management suite, review
the configuration of decisioning services, verify the top level SR class, and configure Pega Marketing
to use Pega Sales Automation cases.

1. Log in to the Pega Platform as an administrator.
2. Click Designer Studio > Decisioning > Infrastructure > Services and verify that all
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decisioning services have the status Normal.

3. Click Designer Studio > Decisioning > Decisions > Proposition Management >
Hierarchy and verify that the top level SR class is set to CRM-SR.
4. Log in to the Pega Platform as any operator who has PegaSA:MarketAdmins as their secondary
access group for the Pega Marketing implementation application.

5. Click Application Name > Switch Application > PegaSA_Marketing to open the PegaSA_
Marketing application.

6. In the Designer Studio header search text field, search for and select the ConfigureNBAA activity.
7. Review the descriptions provided for each of the activity parameters and update the default
parameter values to support your implementation environment.

8. Click Actions > Run .
9. When the activity is complete, open the Records explorer and click Sysadmin > Agent
Schedule.
10. Open the following agents and verify their status:
l

PegaCRM-Artifacts – Enabled

l

PegaNBAM-Artifacts – Not enabled

11. Log off and restart the application server.

Configuring the customer class
To successfully load customer data, a customer class must be configured.
The customer class represents the customer entity in Pega Marketing. The base customer class is

PegaMKT-Data-Customer, which is backed by the MKT_CUSTOMER table in the outbound marketing
schema. Pega Marketing utilizes the external mappings defined on the customer class to load up
customer data.
It is unlikely that your application can use the base customer class as is, except for some limited
demonstration purposes. Typically, to support loading of customer data, you must configure a
different class that extends the base customer class. To do this, complete the following steps:
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l

Creating your customer class

l

Mapping a customer class to a database table

l

Adding associated customer entities

l

Referencing your customer class and its associations

l

Extending and updating the SearchForCustomers report definition

l

Extending and updating the CustomerSearchResultGrid section

Creating your customer class
To support loading customer data, create a customer class that extends the base customer class and
has as its only key the property that you identified in Defining the customer class. The default
customer class key is CustomerID.

1. In the Designer Studio header search text field, enter PegaMKT-Data-Customer, and then select
the PegaMKT-Data-Customer class from the results.
2. Click Save as.
3. Enter the name for the new customer class (for example, MyCo-Data-Customer), and then click
Create and open .
4. In the Keys section, ensure that only the correct key property is listed. The default customer class
key is CustomerID.
5. In the Class inheritance section, select the Find by name first (Pattern) check box, and then
enter PegaMKT-Data-Customer as the parent class.
6. On the External Mapping tab of the class rule, specify the properties available on the customer
record and their backing columns in the customer table. Ensure that these mappings satisfy the
following guidelines:
l

The column name does not exceed 27 characters

l

The property name starts with a period

l

The table contains no empty rows
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Important: Ensure that the following properties are mapped in the customer class: the correct
customer class key, PartitionKey (if partitioning is enabled), pyEmail1 (used by outbound email),
and pyMobilePhone (used by outbound SMS).
7. Click Save.

Mapping a customer class to a database table
After creating and configuring the class rule for your customer, create a database table instance to
map your customer class to a database entity (table or view) in the marketing schema by completing
the following steps.

1. In Designer Studio, click the Records explorer.
a. Expand the SysAdmin category.
b. Right-click the Database Table node, and then select +Create.
2. Enter the name of your customer class and a short description, and then click Create and open .
3. In the Database section, enter details about the backing database entity. Work with the database
administrator to find out what the details are.

4. Click Save.
5. Validate the mapping between your customer class and the specified database table by clicking
Test connectivity.
Note: Whenever changes are made to either the class's external mappings or the columns in the
backing database entity, re-save the database table instance to ensure that the changes are
propagated correctly.

Optional: Creating a custom customer class key property
By default, the key of the customer class is the CustomerID property that is used to store customer
IDs. If your custom customer class uses a different class key, for example, AccountID, then you must
create two copies of this property in your application.

1. In the Designer Studio header search text field, search for and select the CustomerID property that
applies to the Data- class.
2. Click Save as.
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3. In the Label field, enter the name of the property that you identified in Defining the customer
class.

4. In the Add to ruleset section, select your Rules ruleset.
5. Click Create and open .
6. In the Designer Studio header search text field, search for and select the CustomerID property that
applies to the PegaMKT- class.
7. Repeat steps 2 to 5.

Adding associated customer entities
Pega Marketing supports associating the customer class with other entities. For example, each
customer record can have associated purchase data information. After creating the customer class,
create and configure any associated entities.

Note: The relationship with associated entities must be one-to-one or one-to-many.
To add a new association for an entity (for example, PurchaseData) to the customer class, complete
the following steps.

1. Create a property rule for the associated entity directly under the customer class.
a. Ensure that the mode of the property is Page, Page List, or Page Group.
b. Ensure that the page class of the property is the class of the entity.
2. Create an association rule for the entity under the customer class.
a. In the Class association section, enter the class of the entity as the Class name.
b. In the Class join list, add an entry to specify the join between the entity and the customer
class. The Type value is ignored (leave it as Include all rows…). Specify the join criteria by
clicking Edit conditions.
You can use the same procedure to associate nested entities, for example, Branch nested under

PurchaseData. Create the property rule and the association rule for the new entity (for example,
Branch) in the class of the target entity (for example, PurchaseData).
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Note: When using an extended customer class, copy the History association rule and the History
property rule from the base customer class (PegaMKT-Data-Customer) into the extended customer
class. If the customer class has a class key different from the default CustomerID property, then also
update the class join in the History association rule to reference the correct class key.

Referencing your customer class and its associations
After defining and configuring the customer class and its associated entities, update your
application's configuration to reference the new customer class structure.

1. In the Designer Studio header, click Launch > Pega Marketing.
2. In the Pega Marketing portal, click Configuration > Settings > Application Settings.
3. On the Manage Data Relationships tab, click Edit at the bottom of the page, and then enter
your customer class in the Customer Class Name field.
Note: Changing the customer class clears any currently displayed association mappings. If you
want to preserve the previous mappings, click Cancel to discard your current changes.
4. If your customer class has associated entities, you must also map these associations.
a. In the Associated Customer Data section, on the target entity in the associations grid, click
Action , and then select New.
Note: The History association rule and the History property rule are provided under the base
customer class (PegaMKT-Data-Customer). Copy these rules into your extended customer
class.

b. In the Add or Edit Customer Data Source dialog, in the Entity Name field, enter the
property for the entity. In the Association Rule field, enter the entity's backing association. If
either of these values are stored under the correct target class (for example, customer), they
are listed in the smart prompt.

c. Click Submit.
The associations grid displays the new entity under the target entity.

5. Repeat step 4 for each association mapping that you want to add.
6. To save the customer class and its association mappings, click Save in the lower-left corner of the
landing page.
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Extending and updating the SearchForCustomers report definition
After creating a custom customer class, you must extend the rules that are related to list segments.
This is necessary so that your application can use customer data from your extended customer class.
For more information on list segments, see the Pega Marketing User Guide on the Pega Marketing

product page. SearchForCustomers is a report definition that can be used to search customer
details by customer ID or name.

1. In the Designer Studio header search text field, enter searchforcustomers, and then select the
SearchForCustomers report definition from the search results.
2. Click Save as.
3. In the Apply to field, enter the custom customer class that you configured in Creating your
customer class.

4. In the Add to ruleset section, select your Rules ruleset.
5. Click Create and open .
6. Optional: If the custom customer class has a class key different from the default, CustomerID,
update the Query tab.
a. In the Edit columns section, in the Column source column, replace CustomerID with the
name of the correct customer class key, for example, AccountID.
b. In the Edit filters section, in the Column source column, replace CustomerID with the name
of the correct customer class key, for example, AccountID.
7. Click Save.

Extending and updating the CustomerSearchResultGrid section
After creating a custom customer class, you must extend the rules that are related to list segments.
This is necessary so that your application can use customer data from your extended customer class.
For more information on list segments, see the Pega Marketing User Guide on the Pega Marketing

product page. CustomerSearchResultGrid is the default report definition that can be used to display
a segment in a grid based on a segment identifier.

1. In the Designer Studio header search text field, enter customersearchresultgrid, and then select
the CustomerSearchResultGrid section from the search results.
2. Click Save as.
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3. In the Apply to field, enter the custom customer class that you configured in Creating your
customer class.

4. In the Add to ruleset section, select your Rules ruleset.
5. Click Create and open .
6. Click Check out.
7. On the Pages & Classes tab, in the Class column, replace the base customer class name with
the customer class name that you configured in Creating your customer class.

8. On the Design tab, on the Grid Repeat Layout panel, click the Gear icon.
9. Click Submit.
10. Click Save.

Configuring the prospect class
To successfully load prospect data, a prospect class must be configured.
The base prospect class is PegaMKT-Data-Prospect. If the base prospect class is not sufficient for your
business needs, then you must extend the class by creating and configuring a custom prospect class.
For example, if the default configuration does not capture all the potential customer data that you
require, you can adjust the data table that contains prospect information.
Perform the following tasks to configure a custom prospect class:
• Creating a prospect class
• Configuring the prospect template

Creating a prospect class
The base prospect class is PegaMKT-Data-Prospect. If the base prospect class is not sufficient for your
business needs and you want to customize it, you must create a new prospect class. For more
information about the customization, see Configuring the prospect class.
To support loading prospect data, create a prospect class that extends the base prospect class and
has the correct class key.
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1. In the Designer Studio header search text field, enter PegaMKT-Data-Prospect, and then select the
PegaMKT-Data-Prospect class from the search results.
2. Click Save as.
3. Enter the name for the new prospect class, following the pattern <Customer-Class>-Prospect.
l

l

If no customer class is configured, then substitute <Customer-Class> with the base customer
class PegaMKT-Data-Customer.
If a custom customer class is created and configured, then substitute <Customer-Class> with
the custom customer class.

4. Click Create and open .
5. In the Keys section, ensure that only the correct key is listed.
6. In the Class inheritance section, select the Find by name first (Pattern) check box.
7. In the Parent class (Directed) field, enter the base prospect class PegaMKT-Data-Prospect.
8. On the External Mapping tab of the class rule, specify the properties available on the prospect
record and their backing columns in the prospect table. Ensure that these mappings meet the
following requirements:
l

The column name does not exceed 27 characters

l

The property name starts with a period

l

The table does not contain empty rows

9. Click Save.

Configuring the prospect template
Pega Marketing contains a spreadsheet that business users can use to import data from an external
database. The ProspectTemplate binary file contains such columns as name and age. You must
configure the Pega-provided template to meet your business needs. Make the customized binary file
available to the business users to allow them to import prospect data.

1. In the Designer Studio search box, type ProspectTemplate, and then select it from the search
results.

2. Click Save as.
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3. In the Label field, enter a new label for the file.
4. In the Identifier field, enter a new identifier for the file.
5. From the Add to ruleset drop-down list, select your Rules ruleset.
6. Click Create and open .
7. On the File tab of the binary file, click Download file.
8. Edit the file to ensure that the columns in the binary file match the properties on the
External Mapping tab of your prospect class.
9. To upload the edited file, on the File tab of the binary file, click Upload file.
10. In the Upload file window, click Choose file, locate the edited file and click Upload file.

Configuring channels
Channels are a means of communication that customers can use to interact with a company. Pega
Marketing includes integrated, multi-channel support capabilities for managing email, SMS, push
notifications and web-based service interactions. Additionally, in-person interactions can be
conducted using a mobile device, such as a tablet computer.
Pega Marketing allows you to build your process once and reuse it in any channel.
You can configure the following channels.
• Configuring email accounts
• Configuring the outbound SMS account
• Configuring the inbound SMS account
• Specifying delivery time frames
• Configuring push notifications

Configuring email accounts
You can configure the email provider and sender information for your outbound email transactions.
Use these two Pega-provided email accounts for email transactions. Note that both accounts are
outbound email accounts.
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l

l

Default — This system-wide default account for sending emails is also the default account for
sending email and Passbook treatments in offers.
PegaMKT-Work — Used to send campaign-centric emails such as campaign approved and
campaign suspended.

Configure your email accounts with the required information for your email provider and account.

1. Log in to the Pega Marketing portal.
2. Click Configuration > Settings > Channels > Email.
3. On the Email landing page, in the Account Name column, click the email account that you want
to update: Default or PegaMKT-Work.
4. To change the email provider, complete the following steps.
a. Click Select email provider.
b. Select the email provider from the list.
c. Click Submit.
5. Update the values in the Sender section. For more information, see Configuring the email account
in the Email Wizard.

6. To verify that the account information is correct, click Test connectivity.
You receive a summary of the test results. Ensure that the Result column for each step of the test
displays Success, and then click X at the top right of the results window to close the window. If
the test is not successful, correct the account information, and then repeat the test.

7. Click Save.
Note: In addition to these two accounts, you can create other accounts by clicking the Add new
link on the Email landing page. A new account can be referenced as the delivery account in the Send
Email, Send Passbook, and Send Multi shapes in an offer.

Configuring the outbound SMS account
You can configure the SMS server information for outbound SMS transactions. Use the Pega-provided
SMS account named Default for outbound SMS transactions.
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1. Log in to the Pega Marketing portal.
2. Click Configuration > Settings > Channels > SMS.
3. On the SMS landing page, click Edit to the right of the Default (outbound) account, and then
update the account with information for your SMS server.

4. Click OK.
5. In the Connection column, click Test to verify that the account configuration is correct.
You receive a summary of the test results. Ensure that the Result column for each step of the test
displays Success, and then click X at the top right of the results window to close the window. If
the test is not successful, correct the account information, and repeat the test.

Note: In addition to the Default account, you can create other outbound SMS accounts by clicking
the Add new connection button on the SMS landing page. A new account can be referenced as
the SMS delivery account in the Send SMS and Send Multi shapes in an offer.

Configuring the inbound SMS account
You can configure the SMS server information for inbound SMS transactions. An inbound SMS
account is used to listen for customer responses to offers and to take appropriate next actions.

1. Log in to the Pega Marketing portal.
2. Complete the instructions in Configuring an inbound SMS account in the Pega Marketing User
Guide on the Pega Marketing product page.

Specifying delivery time frames
You can specify delivery time frames for outbound SMS and email accounts. The time frames only
apply to the delivery of SMS and email treatments in offers. Other delivery, such as work objectrelated correspondence, is not affected by these time restrictions.

1. In the ACCOUNT AVAILABILITY section, click the Specify Range button.
2. Select the start value From and the end value To of the time range.
3. Ensure that the correct time zone is selected from the drop-down list.
4. Click OK.
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Configuring push notifications
You can register an app so it can receive push notification messages from the Pega Marketing
application. Push notifications allow a server to send (push) a message to the client. For example,
mobile apps can send notification messages to their users.
For more information, see the Push notifications chapter in the Pega Marketing User Guide on the

Pega Marketing product page.
1. Log in to the Pega Marketing portal.
2. Complete the instructions in Registering apps for push notification in the Pega Marketing User
Guide on the Pega Marketing product page.

Configuring Passbook settings
You can configure Passbook settings to enable the sending of Passbook updates with push
notifications. After you upload a valid Apple certificate and a valid organizational certificate, Passbook
is automatically enabled.

1. Log in to the Pega Marketing portal.
2. Complete the instructions in the Passbook settings appendix in the Pega Marketing User Guide on
the Pega Marketing product page.

Reports
In addition to the library of Pega Platform reports, Pega Marketing provides several pre-configured
reports that are customized for the various work objects, cases, and business processes used in the
application. These reports provide you with real-time insights into case inventories and aging so that
you can respond with the agility that is needed to comply with your internal and external service
level agreements as well as compliance mandates.
To create other reports, see Reporting.

Optional: Configuring Adaptive Decision Manager for sales
offers
Adaptive Decision Manager uses customer data to create models that predict the future behavior of
customers. If you want to use Pega Marketing in a CRM suite configuration with Pega Sales
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Automation, you can use the UploadResponses activity to upload sample data or existing customer
data, and prepare Adaptive Decision Manager for sales offers.

1. Log in to the Pega Platform as the Pega Sales Automation administrator operator who has
PegaSA:MarketAdmins as their secondary access group.
2. In the Designer Studio header search box, enter D_NBAContainer, and then select the result. The
D_NBAContainer data page opens.
3. Click Actions > Run to generate the models that need to be trained.
Running this data page extracts the following parameters:
l

ActionID : TopOffers

l

CustomerID : pzinskey of any contact in Pega Sales Automation.

4. Click Application Name > Switch Application and switch to the PegaSA_Marketing or the
Marketing implementation application.

5.
6. In the Designer Studio header search text field, search for and select the UploadResponses activity.
7. Click Actions > Run and provide the proposition name in run time.
8. Click Choose File and browse to the location of the file you want to upload.
Sample response data for propositions is located in the

\ResourceKit\SAMarketingAdaptiveSampleResponses folder on the distribution media.
9. Click Submit.
10. Click Close.
11. Repeat steps 2 through 9 for the remaining proposition sample responses:
l

ReturnOfPRemiumTermLifeInsurance

l

FiveYearTermLifeInsurance

l

MortgageTermLifeInsurance
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Marketing assets configuration
Most Pega Marketing rules are not executable. This is because they are metadata rules and have no
generated run-time behavior. The metadata that these rules carry with them is used to do work on a
user's behalf.
Implementation layer rules in Pega Marketing reside in one of the two implementation layer rulesets:
Rules and Artifacts. To configure your marketing assets, you must create instances of any of the rule
types listed below within the relevant Business Issue/Group context. For more information on
configuring marketing assets, see the Pega Marketing User Guide on the Pega Marketing product

page.

Rule types in the Artifacts ruleset
The first set of rule types reside in the Artifacts ruleset and can change based on the needs of the
marketing team. These rules can be divided into two groups, depending on where they are
automatically published.
You can find these rules by going to the Application Explorer. For more information, see Using the

Application Explorer.
l

Rule types that are automatically published to an internal Pega Marketing class PegaMKT-Work-

Offer-<issue>-<group>:
Offer - Rule-Obj-Flow-Offer
Email - Rule-Obj-Treatment-Outbound
SMS - Rule-Obj-Corr-SMS
Passbook - Rule-PegaMKT-Passbook
Volume Constraint - Rule-Obj-VolConstraintGrp
Real-Time Event - Rule-PegaMKT-Event
Real-Time Container - Rule-PegaMKT-Container
Output Template - Rule-Obj-Template
Geofence - Rule-PegaMKT-Geofence
l

Rule types that are automatically published to your configured customer class:
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Segment - Rule-Obj-Report-Definition-Segment
Strategy - Rule-Decision-Strategy
Analysis Project - Rule-Obj-Analysis
Sample Population - Rule-Obj-Report-Definition-Segment-Sample
Contact Policy - Rule-PegaMKT-ContactPolicy

Revision management
Revision management enables marketing users to revision, package, and import marketing artifacts.
They can make controlled changes in the business sandbox and test these in production within the
boundaries defined by IT. The users can see their assigned change requests in the My Work and
Revision Management widgets.
For more information, see Revision management

Rule types in the Rules ruleset
The second set of rules are saved to a Rules ruleset in your configured customer class and are
typically not changed after the implementation is complete.
You can find these rules by following the hierarchy and rules under the newly-created customer class
in the Application Explorer.
l

Customer - Rule-Obj-Property

l

Segment - Rule-Obj-Association

Note: If you change the customer class midway through the implementation process, the
previously-created segments or strategies no longer display in the Marketing portal. To access them
in Designer Studio, you must navigate to the original customer class.

Optional: Running a marketing campaign for batch
evaluation
If you want to use Pega Marketing in a CRM suite configuration with Pega Sales Automation, you can
test the integration by configuring a campaign to run at a specified time every day to populate next
best offers for each contact. Use contacts from Pega Sales Automation as the campaign segment.
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1. Log in to the Pega Platform as the Pega Sales Automation administrator operator who has
PegaSA:MarketAdmins as their secondary access group.
2. Click Application Name > Switch Application > PegaSA_Marketing to open the PegaSA_
Marketing application.

3. In the Explorer panel, click App.
4. Click PegaCRM-Data-Customer > Marketing > Segment and open the AllSFACustomers
segment.

5. Click Actions > Refresh .
6. Click Actions > Run .
7. In the Designer Studio header search text field, search for and select the RunProgram activity.
8. Enter a unique Program Name, and then enter the same program name as a parameter to the
activity.

9. Click Actions > Run .
10. On the Marketing Campaign form, click Actions > Submit for Execution .
11. Click Confirm.
When the campaign finishes running, the status changes to Pending-Wrapup.

12. Click Launch > Pega Marketing.
13. Click Configuration > Settings > Channels > Database.
14. Locate the row containing the SFAPrioritizedContacts template and ensure that the number of
records equals the total offers initiated on the Run Summary and that the status for the template is
In Progress.

15. In the Actions column, select Finalized.

Verifying the System Health page
After building your implementation features, check the System Health page for any errors or
warnings.
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1. Log in to the Pega Marketing portal.
2. Click Configuration > Settings > System Health .
3. Review and address any errors or warnings.

Testing a new application
Testing a new application includes the following procedures:
• Testing your application in the Build environment
• Testing in the Test or Production environments
• Testing in the UAT environment

Testing your application in the Build environment
Test a new application in the Build environment before migrating the new application to a Test or
Production environment. Testing in the Build environment enables you to verify that basic
functionality and interfaces work correctly and also that performance is acceptable.

1. Run functional tests to test specific features from the end-user perspective.
2. Use the Performance tool to measure the performance of the application. For information about
the Performance tool, see About the Performance tool.
l

l

Prior to extending your site-specific Pega implementation, establish a performance benchmark
(baseline) using the Performance tool. This allows subsequent, iterative performance tests
against the established baseline to help identify any degradation in performance resulting from
development efforts.
Use the Performance tool to check the performance of the following features:
Search
Account selection
Loading of components
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Kickoff of all service intents. For this unit testing, automated scripts are recommended but
not required.
l

Save the test results so that you can compare them to future test results to determine whether
an application update has a performance impact.

3. Verify that the Pega-provided reports and your custom reports run successfully, and that they
show your implementation layer data, rather than the default demonstration data. This can be an
automated test.

4. Test all integrations, both independently and with associated integrations.
Test integrations for any optional Pega Marketing components and other applications that you
plan to use. See the product documentation for the component or application to determine which
product components to test.

5. Test security. Test the most common roles to ensure that the required access groups are
configured and point to the correct software version.

Testing in the Test or Production environments
After you import the application to a Test or Production environment, test the application in the new
environment to verify that it works correctly in that environment.

1. Verify that the source and the destination files are the same.
2. Run functional tests to test specific features from the end-user perspective.
3. In the Test or Production environment, run the Application Guardrails Compliance Score to ensure
that the application meets guardrails.

4. Verify that the Pega-provided reports and your custom reports run successfully, and that they
show your implementation layer data, rather than the default demonstration data. This can be an
automated test.

5. Test all integrations, both independently and with associated integrations.
Test integrations for any optional Pega Marketing components and other applications that you
plan to use. See the product documentation for the component or application to determine which
product components to test.

6. Verify that the integrations point to the correct system of record, and not to the system of record
for the Build environment.
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7. Test security. Test the most common roles to ensure that the required access groups are
configured and point to the correct software version. Use these common roles in your smoke tests
(see next step).

8. Run a smoke test to compare the source and destination environments. Verify that all tests that
pass in the Build environment also pass in the Test or Production environment. If anything fails,
compare the environments to determine whether a difference in environment could cause the test
to fail. If the environment caused the failure, either fix the issue that caused the failure or adjust
the test as appropriate for the new environment.

9. Run performance tests to verify that performance meets expectations. Pega recommends
automated performance testing. Save the results so that you can compare them to future
performance test results to determine whether an application update has a performance impact.

Testing in the UAT environment
After you complete testing in a Test environment, it is common to perform User Acceptance Testing
(UAT) in a designated UAT environment, which could be a pre-production environment. UAT ensures
that end users will be able to successfully complete work and meet business objectives.

Note: Organizations that use Scrum for application development will complete less formal UAT as
part of each sprint cycle.

1. Verify the integrity of the UAT environment.
2. Have the end-users (or business analysts acting the role of end-users) run scripts to test all
scenarios including boundary and exception testing. The end-users (that is, the trainers, managers,
and directors), perform the following steps during UAT:
l

Verify that there are no major issues.

l

Review changes in order to better understand the features.

Packaging a new application
To migrate a new application to a different environment, you must first package the application so
that it can be imported to the new environment.
Packaging and importing a new application includes the following procedures:
• Merging application changes
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• Packaging an application for migration
• Importing the packaged application

Merging application changes
If you developed your application features in separate branches, use the Merge Branches wizard to
merge the branches before you package the application. The wizard shows any merge conflicts so
that you can correct them before you merge the branches.
For more information about using Merge Branches wizard, see Branch development.
Additionally, the revision management capability allows business users to make controlled changes
in the business sandbox and test the changes in a production environment within the boundaries
defined by IT. For more information, see Revision management.

Packaging an application for migration
Before you can migrate a new application to a different environment, you must package the relevant
data instances and rulesets into a product rule. The product rule is an instance of Rule-Admin-

Product, and it is referred to as the RAP file.
1. Click Designer Studio > Application > Distribution > Package to start the Application
Packaging wizard. For information about using the wizard, see Application Packaging wizard.

2. Complete each page of the Application Packaging wizard.
3. On the last page of the wizard, click Preview.
4. Review the contents of the generated RAP file.
5. On the last page of the wizard, click Modify to make any changes.
6. When the RAP file is complete, click Export. The wizard creates a .ZIP file in the ServiceExport
directory on the current application server node.

Importing the packaged application
To deploy a new application to a different environment, import the .ZIP file that contains the
packaged application to the new environment.
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1. Click Designer Studio > Application > Distribution > Import.
2. Use the Import Gadget to import the target .ZIP file. For more information, see Import wizard
landing page.
For information about how to swap the database connection pointers to your Production database
after an import to a Production environment, see Pega Platform Upgrade Guide.
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Production maintenance and monitoring

Production maintenance and
monitoring
Production maintenance and monitoring includes the following procedures:
• Application health monitoring
• Identifying and reporting issues
• Revision management
• Business rule maintenance in the Production environment

Application health monitoring
Pega Autonomic Event Services is an application that automatically monitors, retrieves, and
organizes the alert data from one or more clustered systems throughout the enterprise. Pega also
provides the Pega Predictive Diagnostic Cloud, which allows you to benefit from Pega Autonomic
Event Services without installing it locally. Pega Predictive Diagnostic Cloud is a Software as a Service
offering of Pega Autonomic Event Services.
Implementing the following best practices in your application can help to ensure optimal response
times and overall application health:
l

l

l

l

Segment application agent processing to a dedicated JVM (Java Virtual Machine). This configuration
ensures that end users do not have to share resources with background processes.
Monitor integration response time. Over time, slow integration points can cause average handle
times to increase. When queues start to grow, it becomes very difficult to recover, which might
require usage of offline services or a backup application.
Monitor social accounts (for example, your Facebook and Twitter accounts) to ensure that they do
not expire.
Regularly perform a health check using the Pega Marketing System Health diagnostic tool. Resolve
any issues shown as errors, and review warnings. For more information, see the System Health
appendix in the Pega Marketing User Guide on the Pega Marketing product page.

l

Ensure that you are aware of the Pega Marketing agents and their characteristics. This helps assess
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the impact of any possible failures in these agents. For more information, see Pega Marketing
agents.
l

l

l

Regularly check the email accounts configuration. This helps avoid unnecessary exceptions and
errors. Ensure that all email accounts are connected to a working email server, and that there are
no outbound email accounts configured that are not needed.
Ensure that all Pega Platform operator accounts used by your Pega Marketing application have a
valid email address. This also applies to the accounts of managers, system administrators and
application administrators.
Configure the System Management application with access to the nodes in the system. For more
information, see The System Management application.

Identifying and reporting issues
As with any application, your users will encounter issues that they need to report as they begin to use
the application. When deploying your application to the production environment, complete the
following steps:

1. Identify operational staff who will be responsible for responding to issues reported in the
production environment.

2. Establish procedures with those resources to triage, respond to, and escalate issues.
3. Determine procedures for delivery of changes to the production environment.

Revision management
Revision management is a Pega Platform feature that enables business users to take ownership of
parts of the enterprise application. Users can make controlled changes in the business sandbox and
test the changes in a production environment within the boundaries defined by IT.
Most marketing artifacts can be included and updated in revisions. Revision managers can start a
new revision and create change requests within the revision. A change request can contain marketing
rules and be assigned to a marketer.
These two widgets can be used by marketers to view their assigned change requests:

Pega Marketing Implementation Guide

58

Production maintenance and monitoring

l

The My Work widget

l

The Revision Management widget
Added to a user's Home page in the Pega Marketing portal
Displays change requests that are assigned to the user, and lists each rule within the request
Enables a user to directly access the rules within an assigned change request

There are three roles involved in revision management:
l

DecisionManager:RevisionManager - includes the ability to create a revision and change request.

l

DecisionManager:StrategyDesigner - can be assigned a change request to work on.

l

DecisionManager:PegaMarketing - includes both of the above roles to allow running campaigns
from the application overlay context.

Note: Even when revision management is used, an artifacts ruleset with an unlocked ruleset version
is still required to store rules generated at runtime.
For more information, see the Revision Management chapter in the Pega Marketing User Guide
available on the Pega Marketing product page.

Business rule maintenance in the Production environment
In addition to revision management, you can give managers the ability to update other rule types in
the Production environment. For example, managers can update the Goals and Deadline for a certain
case type. These rules must be delegated in Designer Studio first. After the rule has been delegated,
you can access it by clicking your operator profile > My rules. For more information on rule
delegation, see Delegating a rule or data type.
Managers can also create reports in the Reports section of the portal. For more information, see

Report Browser features.
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