Support Article
Global search not working
SA-36888
Summary
Search is not fetching results in interaction portal and also in the Designer Studio.
Error Messages
Not Applicable
Steps to Reproduce
- Launch interaction portal.
- Search with any existing work object.
- Verify no search results are being displayed.
Root Cause
An issue in the custom application code or rules.
In the user's environment, a node ID on the search landing page is not matching with the node ID on the clipboard system pages > pxRequestor > Node ID. The PR_SYS_SYSTEMNODES table has two entries. The clipboard node ID and ID in the table. The search page node ID needs to be changed.
Resolution
Perform the following local-change:
- Delete the current node configuration on the search landing page.
- Add a new node configuration with the node ID matching as per the node on clipboard system pages > pxRequestor > Node ID.
- Submit the changes.
- Log out of the application.
- Re-check the configuration using the 'Check' button. Verify that 'Rule index File Unavailable or Corrupted' is not getting displayed.
- Re-execute the indexing for ALL, DATA and WORK.
- Search for the WorkObject.
- Check the results and verify by clicking the link from the search result.
Published April 25, 2017 - Updated October 8, 2020
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