Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Grid headers do not render property references in field values

SA-9859

Summary



When using a property reference in a field value to render the label of a grid header, special characters do not render correctly.

For example, the header below should read "INVALID () DISPLAY":



Error Messages



Not Applicable

Steps to Reproduce



1. Set header label to a field value:



2. Define the field value to use a property reference:



3. Set the value of the property to include special characters (for example, parentheses):



Root Cause



Field values that are defined to use property references as their value do not properly decode any encoded special characters in the value string.

Resolution



This issue is scheduled to be resolved in Pega 7.1.9.

the below Local-change works as an interim solution:

Use a formatted text control instead of a field value.







This yields the desired results.

Suggest Edit

Published June 12, 2015 - Updated October 8, 2020

Did you find this content helpful? Yes No

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us