Support Article

IE 11 compatibility issue with Pega 7

SA-34567

 

Summary

Internet Explorer is being forced to run the Pega application (Pega 7) in compatibility mode which causes some UI issues.

In this case the vertical scrollbars gets frozen and users are not able to scroll to view the bottom content of the screens.

 

Error Messages

Not Applicable

 

Steps to Reproduce

  1. Attempt to use a Pega 7 application with Internet Explorer in compatibility mode.
  2. Observe that behavior may vary depending on application configuration.

 

Root Cause

Pega 7 applications are not designed to run in compatibility mode. Standards mode must be used.

 

Resolution

In this case the compatibility mode is being enforced by group policy the following local-changes can be implemented.

1. Override when rule pyUnsupportedBrowsers as described in the PDN article:

https://pdn.pega.com/modifying-unsupported-browser-lists-and-error-messages

2. Update the top level Harness(es) to set the Internet Explorer Document mode to "IE=Edge
".


 

Published March 6, 2017 - Updated June 27, 2018

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