Support Article
PegaCall ICM Call RouterCallKey data not provided on clipboard
SA-41614
Summary
The complete call data, such as RouterCallKey, from the ICM is not mapped onto the Pega clipboard by the CallDelivered Event.
Below is a sample ICM router call key
04:49:27:404 Trace: RouterCallKey=152086 1032 CampaignID=-1 QueryRuleID=-1
Error Messages
Not Applicable
Steps to Reproduce
Push a call from ICM to Pega. The ICM "RouterCallKey" is not mapped to a property in PegaCall.
Root Cause
This issue was determined to be a product enhancement request, which is natively available in Pega Call 7.1.3.1 and later.
Resolution
Pega Call 7.1.3.1 (which requires Pega Platform 7.1.8+) and onward natively support RouterCallKey. In 7.1.3 for Pega Platform 7.1.7 this enhancement has been back-ported and is available in patch HFix-35815.
Published August 26, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.