Support Article
Unable to start email listener
SA-32027
Summary
System Management Application (SMA) fails to start the Email Listener for Receiver.
Error Messages
Start Listener Status
Listener 'Data-Admin-Connect-
EmailListener:FFTaskEmailListener.Listener(com.pega.pegarules.integration.engine.internal.services.email.EmailListener)/0' failed to
start because of the following error:
Failed to launch listener, com.pega.pegarules.pub.PRException: Unable to start email listener 'Listener.FFTaskEmailListener'. Please
check that Data-Admin-ServicePackage instance 'EmailDefault' and Rule-Service-Email instance 'CreateStartFFTask' both exist.
Steps to Reproduce
Start Email Listener from SMA.
Root Cause
A defect or configuration issue in the operating environment: The application deployed (PRPC) is unable to connect to Mail Server with the provided credentials for Receiver.
Resolution
Perform the following local-change:
- Enable DEBUG logging on the Email Listener. This will also turn on JavaMail DEBUG logging, which goes to Standard Out and recreates the issue.
- Locate the log where the App Server writes Standard Out.
- Verify the PegaRules.logs where the Email Listener DEBUG goes.
- Confirm that the Exchange Server 2010 issues a LOGINDISABLED in the cases where PRPC (Java Mail API) reports the exception above.
- Re-configure the Exchange Server 2010.
Published January 3, 2017 - Updated October 8, 2020
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