Support Article
System Queue Management NonexistentTable pr_sys_queues_bix
SA-12126
Summary
When developers and administrator are accessing the System Queue Management link from SMA, they were getting non-existent table 'PEGA_RULES.PR_SYS_QUEUES_BIX' error traces.

Error Messages
ERROR - Exception during engine invocation: com.pega.pegarules.management.internal.SystemQueueManagementAPI.SystemQueueSummary
com.pega.pegarules.pub.context.PRQueueException: System Queue class System-Queue- maps to non-existent table 'PEGA_RULES.pr_sys_queues_bix'
Steps to Reproduce
SMA-> System Queue Management
Root Cause
BIX ruleset was installed however, the BIX specific tables were not created prior to importing the BIX ruleset.
Resolution
Run the BIX install script which will create the BIX specific tables - PR_EXTRACT_TIME and PR_SYS_QUEUES_BIX
Published July 14, 2015 - Updated October 8, 2020
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