Support Article
Rule set cannot be locked because it has checked out rules error
SA-16349
Summary
User is unable to check-in the rule as it is locked
Error Messages
Rule set cannot be locked because it has checked out rules
Steps to Reproduce
Not Applicable.
Root Cause
The user checked-out a rule and modified it. Before checking in the when rule, the system became hanged. User was unable to check-in after system was back up and logged-in with same operator. It is showing that the rule is locked by the Operator ID. As a result, the rule became corrupted.
Resolution
For the corrupted when rule the ReleaseLock option was available to an administrator in the actions menu. User is then able to unlock the checked out record using ReleaseLock option.
Published January 31, 2016 - Updated October 8, 2020
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