Support Article
& displays for blank line in the mail body
SA-95169
Summary
User has an email listener. When the user replies from the functional mailbox, the '&' text is added in a blank line. This occurs when replying to a mail with HTML and Rich Text format. However, when replying to a mail with plain text format, the '&' text is not added.


Error Messages
Not Applicable
Steps to Reproduce
- Send an email to the application using RichText or HTML Format option on Microsoft Outlook. Verify the received data in the email body.
- Parse the email body using a custom activity. The data is populated on the UI for a Text Area control and other fields. The '&' is displays in them.
Root Cause
An issue in the custom application code or rules.
A custom activity was used to parse email data which had HTML tags and a new line ' ' was added. In the custom activity, a Java step was included where HTML tags were replaced with empty strings. Instead of providing ' ', 'nbsp;' was provided to replace the string to empty. Hence, the '&' was carried out with the body data.
Resolution
Perform the following local-change:
In the Java code, include ' ' instead of 'nbsp;'.
Published December 19, 2019 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.