Support Article
SLA on Assignment Service is not working
SA-21654
Summary
On configuring an AssignmentService shape in a flow with SLA defined on it.
And by clicking it 'From external Service' from the OtherActions, system throws error.
Error Messages
The Pega-Procom Agent is unable to open the Rule-Obj-ServiceLevel OXX-Intl-SXXXL-Work-STC-XXX.. This may be due to one of the following reasons: 1. The ruleset of the service level is not present in the Pega-ProCom Data-Agent-Queue's access group. In that case, either add the ruleset to the Agent's access group, or specify a different one for it. 2. The service level does not exist. Carefully check the class and spelling. 3. A database error occurred. The Agent is running on X0XXXX16L using the access group SXXXXX:Administrators and has the following ruleset list:
Steps to Reproduce
1. Create a case with a stage and a step.
2. Create the flow in the first step with an Assignment Service shape and a SLA with Goal set to two minutes.
3. Run the case and close it.
4. Open the case after two minutes.
5. Go to Other Actions > Click on waiting for external service to respond.
6. Observe the above mentioned error message.
Root Cause
When the 'assignment service' assignment page is created, the SLA name is not set on the assignment page through 'DefineSLATimes' activity.
Resolution
Apply HFix-26924.
Published April 6, 2016 - Updated October 8, 2020
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