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Support Article

Incorrect Interaction ID passed for customers in multiple tabs

SA-102728

Summary



Pega Customer Service (CS) 8.3 is installed on Pega Platform 8.3.1.
Post upgrade to Pega Platform 8.3.1, when the user launches two interactions and switches back to the first interaction, the account number changes.


Error Messages



Not Applicable


Steps to Reproduce

  1. Upgrade Pega Platform 7.3.1 to Pega Platform 8.3.1.
  2. Search for a customer. Customer 360 displays with an Interaction ID, I-1. The Customer account number displays as AC-1.
  3. Search for another customer. Customer 360 displays with an Interaction ID, I-2. The Customer Account number displays as AC-2 (without closing the first interaction).
  4. Click the first tab (I-1). The Customer Account changes to AC-2 instead of AC-1. Accounts of the previous Interaction (I-1) display.


Root Cause



An issue in the custom application code or rule.

The D_CPMPortalContext.pyID is passed as a parameter to the Account number dropdown.
Due to the Tab functionality change, the D_CPMPortalContext is not updated when the user switches tabs in the Pega Interaction portal.


Resolution



As a local-change, use pyWorkPage.CurrentInteractionID instead of D_CPMPortalContext.pyID.

Published March 12, 2020 - Updated December 2, 2021

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