Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Not able to get ip addr from pyRemoteAddr in clipboard

SA-35822

Summary



The Client IP address in Requestor Page (pxReqRemoteAddr and pxReqRemoteHost) is empty in Clipboard

After updated server.xml with the below parameter, User can able to see the client IP on pega log file. but still could not visible on the clipboard.

<Valve className="org.apache.catalina.valves.RemoteIpValve"
remotelpHeader="x-forwarded-for"
proxiesHeader="x-forwarded-by"
protocolHeader="x-forwarded-proto" />



Error Messages



Not Applicable

Steps to Reproduce

  1. Open PRPC 7.2 Version
  2. Clipboard > System Pages > pxRequestor > pxReqRemoteAddr and pxReqRemoteHost is empty


Root Cause



An issue in the custom application code or rules.ContextRewriteEnabled is enabled on the application server.
If it is enabled, In clipboard, pxReqServer and pxReqServerPort of requestorPage will be present &
pxReqRemoteAddr and pxReqRemoteHost

Resolution



Perform the following local-change:
Add the below DSS settings in the application server prconfig.xml file.

<env name="initialization/ContextRewriteEnabled" value="false"/>

Published March 31, 2017 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice