Support Article
obj-save failure when executing the GetNextWork
SA-48277
Summary
obj-save failure when clicking the Get Additional Cases button to fetch a new case. This issue occurs when the lock is not held on the case and the subsequent step of Commit also fails.
Error Messages
For failure of Save:
453 [tp-bio-8443-exec-240] [TABTHREAD3] [ ] (Work_Interaction_Social.Action) ERROR - obj-save failed.
com.pega.pegarules.pub.database.LockGoneException
Commit error:
461 [tp-bio-8443-exec-240] [TABTHREAD3] [ ] ( internal.access.DatabaseImpl) ERROR- A commit cannot be performed because a deferred save of instance failed
Deferred Save exception:
461 [tp-bio-8443-exec-240] [TABTHREAD3] [ ] ( internal.access.DatabaseImpl) ERROR - The deferred save failed with the following exception
com.pega.pegarules.pub.database.LockGoneException
Commit error:
466 [tp-bio-8443-exec-240] [TABTHREAD3] [ ] (Work_Interaction_Social.Action) ERROR - Error in commit()
com.pega.pegarules.pub.database.DatabaseException: A commit cannot be performed because a deferred save of instance <none> SQLState: <none> Message: <none>
From: (unknown)
Incorrect information logged:
2017-11-13 13:37:53,471 [tp-bio-8443-exec-240] [TABTHREAD3] [ ] (Work_Interaction_Social.Action) INFO - The operator ID - is using an expired access token. Please re-authorize.
Steps to Reproduce
- Log in to the Case Manager portal.
- Click the Get Additional Cases button. New case is assigned and the assignment opens.
- Verify the log and filter with the operator ID or scroll to the end of the log.
Root Cause
The lock must have been acquired before saving or committing the work object. The lock was not held due to the Optimistic lock configuration on the case type.
Resolution
Apply HFix-39435.
Published January 20, 2018 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.