Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

&amp displays for blank line in the mail body

SA-95169

Summary



User has an email listener. When the user replies from the functional mailbox, the '&' text is added in a blank line. This occurs when replying to a mail with HTML and Rich Text format. However, when replying to a mail with plain text format, the '&' text is not added.





Error Messages



Not Applicable


Steps to Reproduce

  1. Send an email to the application using RichText or HTML Format option on Microsoft Outlook. Verify the received data in the email body.
  2. Parse the email body using a custom activity. The data is populated on the UI for a Text Area control and other fields. The '&' is displays in them.


Root Cause



An issue in the custom application code or rules.
A custom activity was used to parse email data which had HTML tags and a new line ' ' was added. In the custom activity, a Java step was included where HTML tags were replaced with empty strings. Instead of providing ' ', 'nbsp;' was provided to replace the string to empty. Hence, the '&' was carried out with the body data.



Resolution



Perform the following local-change:

In the Java code, include ' ' instead of 'nbsp;'.

Published December 19, 2019 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us