Support Article
Bulk Actions Menu performance is slow
SA-25339
Summary
Bulk Actions Menu item is taking long time to load the menu items.
Error Messages
Not Applicable.
Steps to Reproduce
1. Log into a user portal.
2. Launch bulk actions from operator menu.
3. In bulk actions process search, add filter conditions and click on search. At least 500 items should be displayed in the grid.
Note: Remove pagination from grid.
4. Now select checkbox in each row to set items to be processed.
5. Click "Select Action" Menu button. It will take some time to display Menu items.
Root Cause
A software use or operation error : User has configured refresh other section on button and then configured to load menu.
As the refresh other section is taking time to load the subsequent menu is loading slow.
Resolution
Perform following-local change:
1) Configure "refresh current row" action on the repeat grid checkbox.
2) Remove the refresh other section on button.
Published July 15, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.