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Support Article

Bulk Transfer did not process all items selected

SA-3403

Summary



A user has observed that when working with the Bulk Process work area: if three or more SEQUENTIAL cases are selected, and the user selects to transfer the items to another worklist, only some of the items are actually moved to the other worklist - some work items are not moved.

Error Messages



No errors are found in the Pega Logfile; no error messages are displayed on screen.

Steps to Reproduce



To reproduce this issue:

1) User logs into PRPC with sufficient rights to utilize bulk process (ie WorkManager or Manager access group)
2) User selects Bulk Processing Option, to move items to a WorkList
3) User then selects three or more SEQUENTIAL items - not items randomly on the list
4) User then selects to perform the Bulk Processing (do not select process in background)
5) Observe list: notice that not all items were moved to the new worklist.


NOTE: selection of items in the list has to occur "quickly".

Root Cause



The root cause of this problem is a defect in Pegasystems’ code/rules.

If items are selected "too quickly" not all are passed back to the PRPC server.


Resolution



This issue is resolved in Maintenance Level (ML) release 7.1.7.

Published January 31, 2016 - Updated October 8, 2020

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