Support Article
Must Understand check failed for custom SOAP header
SA-26023
Summary
For a Service call with a custom SOAP Header, the user gets the error Must Understand check failed for Custom SOAP header. The same request is successful with the SOAP UI.
Error Messages
Must Understand check failed for header http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd : Security
Steps to Reproduce
Create a Service call with a custom SOAP Header.
Root Cause
The SOAP Connect rule is implemented using a SOAP header without a namespace.
Resolution
Specify the Dynamic System Setting:
Owning ruleset: Pega-IntegrationEngine
Purpose: DisableMustunderstandHeader
Value: true
Published September 21, 2018 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.