Support Article
Properties created not being fetched when searched for
SA-36903
Summary
User has created rules and tried searching for the newly created rules but could not search for them.
After reindexing is performed, only then the user is able to search for the newly created property.
Error Messages
Unable to search for newly created properties/rules unless reindexing is performed explicitly.
Steps to Reproduce
1. Create and save the rule.
2. Try searching for the rule in the global search provided.
Observe that the rule is not getting search unless reindex is performed.
Root Cause
The issue was because of the agents "SystemIdexer", "SystemWorkIndexer", "SystemPulse" that are responsible for the search (lucene) are disabled on the node.
Resolution
Enable all the required agents for indexing or searching:
- SystemIndexer agent is responsible for updating the search index cache for rules and data instances.
- SystemWorkIndexer is used for updating the indexes to support searches for work items.
- SystemPulse is used for synchronizing the rule changes across all the nodes.
Published May 9, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.