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Support Article

pxForceCaseClose updates cases already Resolved

SA-13192

Summary



The Pega-provided activity pxForceCaseClose is used to close open child cases and the parent case. Unexpectedly, the activity updates all child cases including cases with a status of Resolved.


Error Messages



Not Applicable


Steps to Reproduce

  1. Create a parent case with two child cases.
  2. Resolve a child case using normal resolution process.
  3. Now call the Pega-provided activity pxForceCaseClose with the expected parameters.
  4. Notice that the activity updates child cases that are already resolved.


Root Cause



The behavior reported is correct; the Pega-provided activity pxForceCaseClose is working as designed. The activity does not have a When condition to avoid updating previously resolved child cases:


pxForceCaseClose activity

Resolution



Perform the following local-change to customize a copy of the Pega-provided activity (final rule) pxForceCaseClose:

1. Copy (Save As) the activity pxForceCaseClose with a different name.
2. Add the Pega-provided property pyStatusWork on the working page.

Add property pyStatusWork to custom pxForceCaseClose

3. Add the Pega-provided When condition to Work-.Resolved to skip the processing step and continue normal iteration.

When Resolved condition


Published February 23, 2018 - Updated October 8, 2020

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