Support Article
Scheduled reports do not have charts in PDF file
SA-87688
Summary
When Scheduling a task either once or recurring through a Report Browser in PDF format, the PDF file received through an email only fetches columns. The Rows report and chart is not available in the report.
On manually exporting the original chart report to PDF, it renders accurately with chart and other columns or rows.
Follow the instructions provided in the article to export charts in scheduled reports to a PDF file: https://community.pega.com/knowledgebase/exporting-chart-scheduled-report-pdf-file
Error Messages
Not Applicable
Steps to Reproduce
- Open the Report Browser.
- Click Settings at the end of any Chart report.
- Fill out the general Task schedule details.
- Mention the Task Output File format as PDF. The email is received according to the Task Schedule time.
- Open the PDF attachment in the email. The opened PDF attachment does not include any chart.
Root Cause
This issue was determined to be a product enhancement request.
Resolution
An enhancement request, FDBK-61880, is created for consideration by Pega Product Management to implement the feature without PhantomJS dependency.
Published December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.