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Support Article

SQL Code errors when importing CRM 7.31 JAR on a z/OS instance

SA-63026

Summary



During the Pega 7.1.3 upgrade process, PegaCRMSample_DML.jar file import fails with errors.


Error Messages



ERROR CASysAdmin - Save failed for 'PegaCA-Interface-Contact-CommunicationOptions ACUSTOMER!B!Email2!20140202T050000.000 GMT' 
com.pega.pegarules.pub.database.BadTableMappingException: Database-BadTableMapping-TooManyProperties PegaCA-Interface-Contact-CommunicationOptions PEGABLDD.pa_communication_options PegaDATA Class



Steps to Reproduce

  1. Upgrade from PRPC 6.2 SP1 to Pega 7.1.3.
  2. Import PegaCRMSample_DML.jar.


Root Cause



A software use or operation error.
The PegaCRMSample_DDL.jar was not imported before the Product rule that caused the error.



Resolution



Perform the following local-change:
  1. Import PegaCRMSample_DDL.jar RAP file.
  2. Download the DDL changes and have the DBA apply them.
  3. Continue with importing the rest of the content of the Product rule.
  4. Import PegaCRMSample_DML.jar RAP file.

Published August 24, 2018 - Updated December 2, 2021

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