Support Article
Test Coverage report displays 0% coverage
SA-88107
Summary
When creating Test Coverage using the Pega Platform 8.2 Help document, the report displays 0% coverage. This occurs even when the rules are executed successfully during testing.
For more information, refer to: https://community.pega.com/sites/default/files/help_v82/procomhelpmain.htm#designer-studio/testing-rules/generating-application-coverage-report-tsk.htm
Error Messages
Not Applicable
Steps to Reproduce
- Create a New session from the Test Coverage landing page.
- Execute a Manual test case using the Case Manager or Worker portal.
- Log off and log in to the application.
- Click Stop Coverage to stop the coverage.
- Generate the report.
Root Cause
The Logoff activity was customized in the system and the Test Coverage activity was not available in it.
Resolution
Perform the below changes:
- Unlock the Logoff activity.
- Copy the Test Coverage activity from the Pega Logoff activity.
- Add the Test Coverage activity in the Logoff activity.
- Start the Test Coverage.
Published December 2, 2021
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