Support Article
Unable to add attachment with the same name for the case
SA-83023
Summary
S3 bucket is used to store attachments. Error occurs when adding a file with the same name as the attachment.

AWS S3 bucket provided by Pega Cloud (pegacloudfilestorage).

Error Messages
Failed To Save File: The specified file/folder already exists in the target repository. Please specify a different file/folder.
Steps to Reproduce
- Select the 'Store in repository' radio button in the application rule.
- Select any S3 bucket.
- Create a case.
- Upload the same file (with the same name) twice as an attachment.
Root Cause
This behavior is as per Pega product design.
Resolution
Here's the explanation for the reported behavior:
Pega design prevents duplicate files from being stored in the same bucket when S3 repository is configured for storage.
Published August 19, 2019 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.