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Support Article

Unable to launch Pega application after installation

SA-15005

Summary



After installing Pega 7.1.8, the login browser window is unavailable.  
There is an error in the Web Container log, after startup, indicating a TCP/IP port error.


Error Messages



When attempting to get to a login browser window, "RESOURCE UNAVAILABLE" error.  There is no Pega logfile or Pega ALERT log.  However, the Web Container error log contains the following error:

HTTP status 404 - /prweb/prservletThe requested resource is not available


Steps to Reproduce



After completing the installation, a system startup always displays this error.


Root Cause



The Web Container in use is Tomcat 7.  Examination of the ${CATALINA_HOME}/conf/server.xml file reveals that the port definitions for the various Web Container services are defined with default values.  Of particular interest is the HTTP port (default: 8080).  Examination of a NETSTAT output (at the OS) reveals that the port 8080 is already in use by another application. The same is found regarding the HTTPS port (default 8443).


Resolution



Change the port definitions to ports that are not defined in a NETSTAT output.

Published November 3, 2015 - Updated October 8, 2020

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